about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-06-12 06:58:07 +0000
committerMichael Raskin <7c6f434c@mail.ru>2008-06-12 06:58:07 +0000
commite8e0d1665ca18214ad751171d4920893400fa472 (patch)
tree1b3f63a81a874ed0f273a71d1cd07a75e2df854d /pkgs/lib
parent9dd45a58cf552196f4d62502c7c5f8e072316c53 (diff)
downloadnixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar.gz
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar.bz2
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar.lz
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar.xz
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.tar.zst
nixlib-e8e0d1665ca18214ad751171d4920893400fa472.zip
traceWhatIs works for empty lists
svn path=/nixpkgs/trunk/; revision=12046
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/default.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index 2efd1adddb10..af2785f30e54 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -341,6 +341,7 @@ rec {
           if (x ? outPath) then "x is a derivation with name ${x.name}"
           else "x is an attr set with attributes ${builtins.toString (__attrNames x)}"
       else if (__isFunction x) then "x is a function"
+      else if (x == []) then "x is an empty list"
       else if (__isList x) then "x is a list, first item is : ${whatis (__head x)}"
       else if (x == true || x == false) then builtins.toString x
       else "x is probably a string starting, starting characters: ${__substring 0 50 x}..";