about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2008-03-06 02:48:09 +0000
committerMarc Weber <marco-oweber@gmx.de>2008-03-06 02:48:09 +0000
commita277b420eec09b88180ba04cc5d0cf0007497526 (patch)
tree8a48c567494a4e67439bfa55aa2bc9524799f4cf /pkgs/lib
parent1b51b7031715e2b2cbe3e7dd924a87dd617bc20d (diff)
downloadnixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar.gz
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar.bz2
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar.lz
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar.xz
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.tar.zst
nixlib-a277b420eec09b88180ba04cc5d0cf0007497526.zip
annotatedDerivation removed
svn path=/nixpkgs/trunk/; revision=10975
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/annotatedDerivations.nix56
1 files changed, 0 insertions, 56 deletions
diff --git a/pkgs/lib/annotatedDerivations.nix b/pkgs/lib/annotatedDerivations.nix
deleted file mode 100644
index eca97747cd84..000000000000
--- a/pkgs/lib/annotatedDerivations.nix
+++ /dev/null
@@ -1,56 +0,0 @@
-{ lib } : with lib; with builtins; rec {
-  /*
-  # traversal proposal (very unstable now )
-  # goal: create tags easily (and install source files along without recompiling)
-
-  rec {
-    # encouraged: using it you can filter based on names later on? Do we ned it?
-    name = 
-
-    # required: the annotated derivation (this attr is used to identify a
-    # annotated derivation)
-    aDeriv =
-
-    # required: extra list of annotated dependencies, so we can traverse the tree
-    aDeps = <annotated deps>
-
-    # your annotation derivations 
-  };
-  */
-
-  isAnnotated = a : (a ? aDeriv); # this function serves documentation purposes 
-
-  delAnnotation = a :
-    if ((__isAttrs a) && (isAnnotated a)) then  a.aDeriv
-    else a; # most probalby a derivation without annotations.
-
-  # returns buildInputs and propagatedBuildInputs from given set after removing annotations
-  delAnnotationsFromInputs = attrs :
-    subsetmap (map delAnnotation) attrs [ "buildInputs" "propagatedBuildInputs" ];
-
-  /* so an annotated drivation function might look like this
-  args: with args;
-    let aDeps = filterDeps args;
-        deps = delAnnotation aDeps;
-    in rec {
-      name = "my-package-0.2";
-      inherit aDeps;
-
-      aDeriv = stdenv.mkDerivation {
-        inherit name;
-        buildInputs = deps;
-      };
-    };
-
-  */
-
-  filterAnnotated = lib.filter isAnnotated;
-
-  # stops when depthCounter = 0 
-  traverseByDepthCounter = depthCounter : aAttrs :
-    if (depthCounter == 0) then []
-    else [ aAttrs ] ++ map (traverseByDepthCounter (__sub depthCounter 1) ) (filterAnnotated aAttrs.aDeps);
-
-  # get all deps recursively
-  uniqAnnotatedDeps = aAttrs : uniqList { inputList = traverseByDepthCounter 10 aAttrs; };
-}