about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2010-02-18 10:29:40 +0000
committerMichael Raskin <7c6f434c@mail.ru>2010-02-18 10:29:40 +0000
commit89d1b7881f707c1a374af77eef7deae333c27476 (patch)
tree38d219b0a35338c9962808254dcd0b48a52e9d62 /pkgs/lib
parent5fc64e5f9cd6def6a22cb518b5549280af084ebe (diff)
downloadnixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar.gz
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar.bz2
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar.lz
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar.xz
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.tar.zst
nixlib-89d1b7881f707c1a374af77eef7deae333c27476.zip
Update SGT puzzles and improve builderDefs processing of propagated(Native)BuildInputs after stdenv merge
svn path=/nixpkgs/trunk/; revision=20093
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/misc.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/lib/misc.nix b/pkgs/lib/misc.nix
index 05e375dac141..2cfd15735a74 100644
--- a/pkgs/lib/misc.nix
+++ b/pkgs/lib/misc.nix
@@ -196,10 +196,11 @@ rec {
 
 
   innerClosePropagation = ready: list: if list == [] then ready else
-    if (head list) ? propagatedBuildInputs then 
-      innerClosePropagation (ready ++ [(head list)]) 
-        ((head list).propagatedBuildInputs ++ (tail list)) else
-      innerClosePropagation (ready ++ [(head list)]) (tail list);
+    innerClosePropagation 
+      (ready ++ [(head list)])
+      ((tail list) 
+         ++ (maybeAttr "propagatedBuildInputs" [] (head list))
+	 ++ (maybeAttr "propagatedBuildNativeInputs" [] (head list)));
 
   closePropagation = list: (uniqList {inputList = (innerClosePropagation [] list);});