about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorYury G. Kudryashov <urkud.urkud@gmail.com>2007-12-08 01:10:32 +0000
committerYury G. Kudryashov <urkud.urkud@gmail.com>2007-12-08 01:10:32 +0000
commit8515c1796676d1e2c1fb7a6661d73625da5705c2 (patch)
treee3c49d39944ad6f82839a004ec15f269d356baef /pkgs/lib
parent06e55f1ffee68dfef3633afb357b7479a1701733 (diff)
downloadnixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar.gz
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar.bz2
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar.lz
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar.xz
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.tar.zst
nixlib-8515c1796676d1e2c1fb7a6661d73625da5705c2.zip
Added gdmap, changed builder-defs to use derivation attribute on propagatedBuildInputs, manually fixed Xorg expression problem for Compiz, various fixes.
svn path=/nixpkgs/branches/stdenv-updates/; revision=9893
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index 71803a9e3352..3ad861ef19d1 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -252,4 +252,12 @@ rec {
   debugVal = if builtins ? trace then x: (builtins.trace x x) else x: x;
   debugXMLVal = if builtins ? trace then x: (builtins.trace (builtins.toXML x) x) else x: x;
 
+  innerClosePropagation = ready: list: if list == [] then ready else
+    if (head list) ? propagatedBuildInputs then 
+      innerClosePropagation (ready ++ [(head list)]) 
+        ((head list).propagatedBuildInputs ++ (tail list)) else
+      innerClosePropagation (ready ++ [(head list)]) (tail list);
+
+  closePropagation = list: (uniqList {inputList = (innerClosePropagation [] list);});
+
 }