about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2010-03-12 00:01:56 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2010-03-12 00:01:56 +0000
commit7dffd9697859e8002c09caab1d30698151f432e5 (patch)
tree6e3dd9457a6de06e4358c3b086d35b3174c08ffb /pkgs/lib
parent4b7ff33c2693438c22b5ca31985a7d41d3cf631e (diff)
downloadnixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar.gz
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar.bz2
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar.lz
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar.xz
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.tar.zst
nixlib-7dffd9697859e8002c09caab1d30698151f432e5.zip
* Allow `overrideDerivation' to work on derivations to which
  `makeOverridable' has been applied (!).  Ugly.

svn path=/nixpkgs/trunk/; revision=20591
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/customisation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/customisation.nix b/pkgs/lib/customisation.nix
index d5c9e99727e2..e6a26958ae2e 100644
--- a/pkgs/lib/customisation.nix
+++ b/pkgs/lib/customisation.nix
@@ -31,7 +31,7 @@ rec {
   overrideDerivation = drv: f:
     let
       # Filter out special attributes.
-      attrs = removeAttrs drv ["meta" "passthru" "outPath" "drvPath" "hostDrv" "buildDrv" "type"];
+      attrs = removeAttrs drv ["meta" "passthru" "outPath" "drvPath" "hostDrv" "buildDrv" "type" "override" "deepOverride" "origArgs"];
       newDrv = derivation (attrs // (f drv));
     in newDrv //
       { meta = if drv ? meta then drv.meta else {};