about summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2008-04-11 00:40:10 +0000
committerMarc Weber <marco-oweber@gmx.de>2008-04-11 00:40:10 +0000
commit772fd74b99ab85d02014dfd4a721089c291cda61 (patch)
tree7c1eb2665e0708751d194b0491d2be16f6696b3f /pkgs/lib
parent5efc5fe707f0269b1b561fb8e94ef70af66a06e1 (diff)
downloadnixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar.gz
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar.bz2
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar.lz
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar.xz
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.tar.zst
nixlib-772fd74b99ab85d02014dfd4a721089c291cda61.zip
Updated my ghc stuff.
New is the file containing executables (such as alex/ happy)
some new libraries
The wrapper no longer installs tags by default. You have to add it to your config
So I'm ready to start merging

svn path=/nixpkgs/trunk/; revision=11554
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/lib/default.nix b/pkgs/lib/default.nix
index eaeea3af8c1c..a99f09c80dfb 100644
--- a/pkgs/lib/default.nix
+++ b/pkgs/lib/default.nix
@@ -366,6 +366,10 @@ rec {
   # calls a function (f attr value ) for each record item. returns a list
   mapRecordFlatten = f : r : map (attr: f attr (builtins.getAttr attr r) ) (attrNames r);
 
+  # maps a function on each attr value
+  # f = name : attrValue : ..
+  mapAttrs = f : r : listToAttrs ( mapRecordFlatten (n : a : nv n ( f n a ) )  r);
+
   # to be used with listToAttrs (_a_ttribute _v_alue)
   nv = name : value : { inherit name value; };
   # attribute set containing one attribute