about summary refs log tree commit diff
path: root/pkgs/kde
diff options
context:
space:
mode:
authorK900 <me@0upti.me>2024-05-13 08:26:18 +0300
committerK900 <me@0upti.me>2024-05-13 17:36:52 +0300
commit5692481590572c249a3365b09165e370b2be5d7c (patch)
tree55cc815245bd08ec09ae9713d598069c47ec0621 /pkgs/kde
parente526629d759949faea584911171a4e1c71f9cc60 (diff)
downloadnixlib-5692481590572c249a3365b09165e370b2be5d7c.tar
nixlib-5692481590572c249a3365b09165e370b2be5d7c.tar.gz
nixlib-5692481590572c249a3365b09165e370b2be5d7c.tar.bz2
nixlib-5692481590572c249a3365b09165e370b2be5d7c.tar.lz
nixlib-5692481590572c249a3365b09165e370b2be5d7c.tar.xz
nixlib-5692481590572c249a3365b09165e370b2be5d7c.tar.zst
nixlib-5692481590572c249a3365b09165e370b2be5d7c.zip
kdePackages.kdeconnect-kde: hardcode sshfs path, fix sshfs arguments
Fixes #311236
Diffstat (limited to 'pkgs/kde')
-rw-r--r--pkgs/kde/gear/kdeconnect-kde/default.nix4
-rw-r--r--pkgs/kde/gear/kdeconnect-kde/remove-ssh-dss.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/kde/gear/kdeconnect-kde/default.nix b/pkgs/kde/gear/kdeconnect-kde/default.nix
index c8575ee51ea6..2381dd58c868 100644
--- a/pkgs/kde/gear/kdeconnect-kde/default.nix
+++ b/pkgs/kde/gear/kdeconnect-kde/default.nix
@@ -19,6 +19,10 @@ mkKdeDerivation {
       src = ./hardcode-sshfs-path.patch;
       sshfs = lib.getExe sshfs;
     })
+    # We build OpenSSH without ssh-dss support, so sshfs explodes at runtime.
+    # See: https://github.com/NixOS/nixpkgs/commit/6ee4b8c8bf815567f7d0fa131576d2b8c0a18167
+    # FIXME: upstream?
+    ./remove-ssh-dss.patch
   ];
 
   # Hardcoded as a QString, which is UTF-16 so Nix can't pick it up automatically
diff --git a/pkgs/kde/gear/kdeconnect-kde/remove-ssh-dss.patch b/pkgs/kde/gear/kdeconnect-kde/remove-ssh-dss.patch
new file mode 100644
index 000000000000..b404132f4e97
--- /dev/null
+++ b/pkgs/kde/gear/kdeconnect-kde/remove-ssh-dss.patch
@@ -0,0 +1,13 @@
+diff --git a/plugins/sftp/mounter.cpp b/plugins/sftp/mounter.cpp
+index 29e94f3b..0f300c63 100644
+--- a/plugins/sftp/mounter.cpp
++++ b/plugins/sftp/mounter.cpp
+@@ -122,7 +122,7 @@ void Mounter::onPacketReceived(const NetworkPacket &np)
+                       << QStringLiteral("-o") << QStringLiteral("IdentityFile=") + KdeConnectConfig::instance().privateKeyPath()
+                       << QStringLiteral("-o") << QStringLiteral("StrictHostKeyChecking=no") // Do not ask for confirmation because it is not a known host
+                       << QStringLiteral("-o") << QStringLiteral("UserKnownHostsFile=/dev/null") // Prevent storing as a known host
+-                      << QStringLiteral("-o") << QStringLiteral("HostKeyAlgorithms=+ssh-dss\\,ssh-rsa") // https://bugs.kde.org/show_bug.cgi?id=351725
++                      << QStringLiteral("-o") << QStringLiteral("HostKeyAlgorithms=+ssh-rsa") // https://bugs.kde.org/show_bug.cgi?id=351725
+                       << QStringLiteral("-o") << QStringLiteral("PubkeyAcceptedKeyTypes=+ssh-rsa") // https://bugs.kde.org/show_bug.cgi?id=443155
+                       << QStringLiteral("-o") << QStringLiteral("uid=") + QString::number(getuid())
+                       << QStringLiteral("-o") << QStringLiteral("gid=") + QString::number(getgid())