about summary refs log tree commit diff
path: root/pkgs/kde
diff options
context:
space:
mode:
authorK900 <me@0upti.me>2024-04-22 11:44:01 +0300
committerGitHub <noreply@github.com>2024-04-22 11:44:01 +0300
commit45bc5d5b888693b7791d2243bfa7f5f5b48652af (patch)
treef42f9fd98a38f8ade6771181739d334c9fcc3dfc /pkgs/kde
parent3412d90524d2fdf0d4f36a60d44401fdb5159d82 (diff)
parent20cd060754562e439dfe03115482c9c804849643 (diff)
downloadnixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar.gz
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar.bz2
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar.lz
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar.xz
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.tar.zst
nixlib-45bc5d5b888693b7791d2243bfa7f5f5b48652af.zip
Merge pull request #305692 from Naxdy/work/add-python3-to-ecm
kdePackages/ecm: add `python3` to `extraPropagatedBuildInputs`
Diffstat (limited to 'pkgs/kde')
-rw-r--r--pkgs/kde/frameworks/extra-cmake-modules/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/kde/frameworks/extra-cmake-modules/default.nix b/pkgs/kde/frameworks/extra-cmake-modules/default.nix
index 0a06cf4a8772..b7dc85d277a3 100644
--- a/pkgs/kde/frameworks/extra-cmake-modules/default.nix
+++ b/pkgs/kde/frameworks/extra-cmake-modules/default.nix
@@ -1,8 +1,16 @@
-{mkKdeDerivation}:
+{ mkKdeDerivation
+, python3
+}:
 mkKdeDerivation {
   pname = "extra-cmake-modules";
 
-  outputs = ["out"];
+  outputs = [ "out" ];
+
+  # Packages that have an Android APK (e.g. KWeather) require Python3 at build time.
+  # See: https://invent.kde.org/frameworks/extra-cmake-modules/-/blob/v6.1.0/modules/ECMAddAndroidApk.cmake?ref_type=tags#L57
+  propagatedNativeBuildInputs = [
+    python3
+  ];
 
   setupHook = ./ecm-hook.sh;
 }