about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-29 10:13:33 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-29 10:13:33 +0100
commitf29000b0023a879b42be2a8bd59136ec0c533b88 (patch)
tree4b0b2851c7dec0588d236f6d3946b8018a74afb9 /pkgs/games
parent291eac9d70e5f4b8cbbc7632afcac5ea79eb62ba (diff)
parent76c146c99073ad27046a0a28bb3d2881486e32bb (diff)
downloadnixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.gz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.bz2
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.lz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.xz
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.tar.zst
nixlib-f29000b0023a879b42be2a8bd59136ec0c533b88.zip
Merge branch 'master' into staging
Hydra: ?compare=1421760
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/easyrpg-player/default.nix41
-rw-r--r--pkgs/games/scummvm/default.nix7
2 files changed, 44 insertions, 4 deletions
diff --git a/pkgs/games/easyrpg-player/default.nix b/pkgs/games/easyrpg-player/default.nix
new file mode 100644
index 000000000000..be45866a7dd7
--- /dev/null
+++ b/pkgs/games/easyrpg-player/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, fetchFromGitHub, cmake, doxygen ? null, pkgconfig, freetype ? null, harfbuzz ? null
+, liblcf, libpng, libsndfile ? null, libxmp ? null, libvorbis ? null, mpg123 ? null
+, opusfile ? null, pixman, SDL2, speexdsp ? null, wildmidi ? null, zlib }:
+
+stdenv.mkDerivation rec {
+  name = "easyrpg-player-${version}";
+  version = "0.5.3";
+
+  src = fetchFromGitHub {
+    owner = "EasyRPG";
+    repo = "Player";
+    rev = version;
+    sha256 = "1cn3g08ap6cf812s8p3ilf31q7y7y4knp1s0gk45mqcz215cpd8q";
+  };
+
+  nativeBuildInputs = [ cmake doxygen pkgconfig ];
+
+  buildInputs = [
+    freetype
+    harfbuzz
+    liblcf
+    libpng
+    libsndfile
+    libxmp
+    libvorbis
+    mpg123
+    opusfile
+    SDL2
+    pixman
+    speexdsp
+    wildmidi
+    zlib
+  ];
+
+  meta = with stdenv.lib; {
+    homepage = https://easyrpg.org/;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ yegortimoshenko ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/games/scummvm/default.nix b/pkgs/games/scummvm/default.nix
index 893055fa6e9c..29b44f9d8576 100644
--- a/pkgs/games/scummvm/default.nix
+++ b/pkgs/games/scummvm/default.nix
@@ -1,5 +1,5 @@
-{ stdenv, nasm
-, fetchurl, SDL2, SDL2_net, freetype, zlib, libmpeg2, libjpeg, libmad, libogg, libvorbis, flac, alsaLib, mesa
+{ stdenv, fetchurl, nasm
+, alsaLib, flac, fluidsynth, freetype, libjpeg, libmad, libmpeg2, libogg, libvorbis, mesa, SDL2, zlib
 , hostPlatform
 }:
 
@@ -15,8 +15,7 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ nasm ];
 
   buildInputs = [
-    SDL2 SDL2_net
-    freetype libjpeg libmpeg2 libmad libogg libvorbis flac alsaLib mesa zlib
+    alsaLib freetype flac fluidsynth libjpeg libmad libmpeg2 libogg libvorbis mesa SDL2 zlib
   ];
 
   enableParallelBuilding = true;