about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@viric.name>2016-05-08 16:21:46 +0200
committerLluís Batlle i Rossell <viric@viric.name>2016-05-08 16:22:18 +0200
commitf0c503593fd9d968407a94e26f9ef24279bf8012 (patch)
treea6fb6970cc93fd6925f676b57c016c1dee7f6f9a /pkgs/games
parent516f331227d7879c157190f888ad644d8665172d (diff)
downloadnixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar.gz
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar.bz2
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar.lz
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar.xz
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.tar.zst
nixlib-f0c503593fd9d968407a94e26f9ef24279bf8012.zip
Fixing stunt-rally 2.6 (adding newer bullet)
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/stuntrally/default.nix34
1 files changed, 18 insertions, 16 deletions
diff --git a/pkgs/games/stuntrally/default.nix b/pkgs/games/stuntrally/default.nix
index 436ac958f344..24e54c7b13a2 100644
--- a/pkgs/games/stuntrally/default.nix
+++ b/pkgs/games/stuntrally/default.nix
@@ -1,40 +1,42 @@
-{ fetchgit, stdenv, cmake, boost, ogre, mygui, ois, SDL2, libvorbis, pkgconfig
-, makeWrapper, enet, libXcursor }:
+{ fetchurl, stdenv, cmake, boost, ogre, mygui, ois, SDL2, libvorbis, pkgconfig
+, makeWrapper, enet, libXcursor, bullet, openal }:
 
 stdenv.mkDerivation rec {
   name = "stunt-rally-${version}";
   version = "2.6";
 
-  src = fetchgit {
-    url = git://github.com/stuntrally/stuntrally.git;
-    rev = "refs/tags/${version}";
-    sha256 = "0rrfmldl6m7igni1n4rv2i0s2q5j1ik8dh05ydkaqrpcky96bdr8";
+  src = fetchurl {
+    url = "https://github.com/stuntrally/stuntrally/archive/${version}.tar.gz";
+    sha256 = "1jmsxd2isq9q5paz43c3xw11vr5md1ym8h34b768vxr6gp90khwc";
   };
 
-  tracks = fetchgit {
-    url = git://github.com/stuntrally/tracks.git;
-    rev = "refs/tags/${version}";
-    sha256 = "186qqyr1nrabfzsgy7b4sjgm38mgd875f4c7qwkm8k2bl7zjkrm2";
+  tracks = fetchurl {
+    url = "https://github.com/stuntrally/tracks/archive/${version}.tar.gz";
+    sha256 = "0yv88l9s03kp1xkkwnigh0jj593vi3r7vgyg0jn7i8d22q2p1kjb";
   };
 
+  # include/OGRE/OgreException.h:265:126: error: invalid conversion from
+  # 'int' to 'Ogre::Exception::ExceptionCodes' [-fpermissive]
+  NIX_CFLAGS_COMPILE="-fpermissive";
+
   preConfigure = ''
-    cp -R ${tracks} data/tracks
-    chmod u+rwX -R data
+    pushd data
+    tar xf ${tracks}
+    mv tracks-2.6 tracks
+    popd
   '';
 
   buildInputs = [ cmake boost ogre mygui ois SDL2 libvorbis pkgconfig 
-    makeWrapper enet libXcursor
+    makeWrapper enet libXcursor bullet openal
   ];
 
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
     description = "Stunt Rally game with Track Editor, based on VDrift and OGRE";
-    homepage = http://code.google.com/p/vdrift-ogre/;
+    homepage = http://stuntrally.tuxfamily.org/;
     license = licenses.gpl3Plus;
     maintainers = with maintainers; [ pSub ];
     platforms = platforms.linux;
-    # Build failure
-    broken = true;
   };
 }