about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-09-14 22:27:19 -0600
committerMathnerd314 <mathnerd314.gph+hs@gmail.com>2015-09-14 22:27:19 -0600
commiteb7404d97a7e46df1f598a74982ca06e08033a45 (patch)
tree6b5752df7032ba1efc535cf884db4891f20dd786 /pkgs/games
parent7fb1c7efcfa34a4af9f5de5fbde9e12d15017a90 (diff)
downloadnixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.gz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.bz2
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.lz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.xz
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.tar.zst
nixlib-eb7404d97a7e46df1f598a74982ca06e08033a45.zip
all-packages: Use callPackage where possible
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/jamp/default.nix6
-rw-r--r--pkgs/games/lincity/default.nix10
-rw-r--r--pkgs/games/liquidwar/default.nix15
-rw-r--r--pkgs/games/xsokoban/default.nix2
-rw-r--r--pkgs/games/zangband/default.nix2
5 files changed, 20 insertions, 15 deletions
diff --git a/pkgs/games/jamp/default.nix b/pkgs/games/jamp/default.nix
index d9ae4ca738b7..be7abc75915d 100644
--- a/pkgs/games/jamp/default.nix
+++ b/pkgs/games/jamp/default.nix
@@ -1,5 +1,5 @@
-a :  
-let 
+a @ { mesa, SDL, SDL_image, SDL_mixer, ... } :
+let
   s = import ./src-for-default.nix;
   buildInputs = with a; [
     mesa SDL SDL_mixer SDL_image
@@ -21,7 +21,7 @@ rec {
 
   /* doConfigure should be removed if not needed */
   phaseNames = ["preBuild" "doMakeInstall"];
-      
+
   meta = {
     description = "A physics-based game";
     maintainers = [ a.lib.maintainers.raskin ];
diff --git a/pkgs/games/lincity/default.nix b/pkgs/games/lincity/default.nix
index b5c78c98b190..6cd5155e3af1 100644
--- a/pkgs/games/lincity/default.nix
+++ b/pkgs/games/lincity/default.nix
@@ -1,7 +1,7 @@
-args : with args; 
-let 
-  version = lib.attrByPath ["version"] "1.12.1" args; 
-  sha256 = lib.attrByPath ["sha256"] 
+args @ { libX11, libXext, xextproto, libICE, libSM, xproto, libpng, zlib, ... }: with args;
+let
+  version = lib.attrByPath ["version"] "1.12.1" args;
+  sha256 = lib.attrByPath ["sha256"]
     "0xmrp7vkkp1hfblb6nl3rh2651qsbcm21bnncpnma1sf40jaf8wj" args;
   pkgName = "lincity";
 in
@@ -17,7 +17,7 @@ rec {
 
   /* doConfigure should be specified separately */
   phaseNames = ["doConfigure" "doMakeInstall"];
-      
+
   name = "${pkgName}-" + version;
   meta = {
     description = "City simulation game";
diff --git a/pkgs/games/liquidwar/default.nix b/pkgs/games/liquidwar/default.nix
index 3a3774bc1dd3..602daa1ee864 100644
--- a/pkgs/games/liquidwar/default.nix
+++ b/pkgs/games/liquidwar/default.nix
@@ -1,11 +1,16 @@
-a :  
-let 
+a @ { xproto, libX11, libXrender
+, gmp, mesa, libjpeg, libpng
+, expat, gettext, perl
+, SDL, SDL_image, SDL_mixer, SDL_ttf
+, curl, sqlite
+, libogg, libvorbis, libcaca, csound, cunit, ... } :
+let
   buildInputs = with a; [
     xproto libX11 gmp guile
     mesa libjpeg libpng
     expat gettext perl
     SDL SDL_image SDL_mixer SDL_ttf
-    curl sqlite 
+    curl sqlite
     libogg libvorbis csound
     libXrender libcaca cunit
   ];
@@ -27,13 +32,13 @@ rec {
   setVars = a.noDepEntry (''
     export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -I${a.SDL}/include/SDL"
   '');
-      
+
   meta = {
     description = "Quick tactics game";
     maintainers = [
       a.lib.maintainers.raskin
     ];
-    platforms = with a.lib.platforms; 
+    platforms = with a.lib.platforms;
       linux;
   homepage = "http://www.gnu.org/software/liquidwar6/";
   version = "0.6.3902";
diff --git a/pkgs/games/xsokoban/default.nix b/pkgs/games/xsokoban/default.nix
index 8cdf07bb3063..9d442329a245 100644
--- a/pkgs/games/xsokoban/default.nix
+++ b/pkgs/games/xsokoban/default.nix
@@ -1,4 +1,4 @@
-a :
+a @ {libX11, xproto, libXpm, libXt, ...} :
 let
   fetchurl = a.fetchurl;
 
diff --git a/pkgs/games/zangband/default.nix b/pkgs/games/zangband/default.nix
index d7b1c1880769..110eff9397ce 100644
--- a/pkgs/games/zangband/default.nix
+++ b/pkgs/games/zangband/default.nix
@@ -1,4 +1,4 @@
-a :
+a @ { ncurses, flex, bison, autoconf, automake, m4, coreutils, ... } :
 let
   fetchurl = a.fetchurl;