about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorFrancesco Gazzetta <fgaz@fgaz.me>2021-08-17 22:40:48 +0200
committerFrancesco Gazzetta <fgaz@fgaz.me>2021-08-17 22:40:48 +0200
commitea300d1e2d7b8cccf914cbded2ac66170ed70067 (patch)
treeff70fe46654bd41c3253109dbc5f620f39f9155e /pkgs/games
parent6327a87b56a22ce2b28d1bcc6767b02af558fd72 (diff)
downloadnixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar.gz
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar.bz2
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar.lz
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar.xz
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.tar.zst
nixlib-ea300d1e2d7b8cccf914cbded2ac66170ed70067.zip
shattered-pixel-dungeon: 0.9.3 -> 1.0.0
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/shattered-pixel-dungeon/default.nix15
1 files changed, 7 insertions, 8 deletions
diff --git a/pkgs/games/shattered-pixel-dungeon/default.nix b/pkgs/games/shattered-pixel-dungeon/default.nix
index ec18a26829fb..e67a9f6d470e 100644
--- a/pkgs/games/shattered-pixel-dungeon/default.nix
+++ b/pkgs/games/shattered-pixel-dungeon/default.nix
@@ -10,23 +10,23 @@
 
 let
   pname = "shattered-pixel-dungeon";
-  version = "0.9.3";
+  version = "1.0.0";
 
   src = fetchFromGitHub {
     owner = "00-Evan";
     repo = "shattered-pixel-dungeon";
     # NOTE: always use the commit sha, not the tag. Tags _will_ disappear!
     # https://github.com/00-Evan/shattered-pixel-dungeon/issues/596
-    rev = "785c869f2b61013a15fddbf5f0c65d67fe900e80";
-    sha256 = "sha256-d7Fc1IPOW/0RwLYe9vwaD3gFw6div2/J0DOFdWYDXWY=";
+    rev = "1f296a2d1088ad35421f5f8040a9f0803fa46ba8";
+    sha256 = "sha256-MzHdUAzCR2JtIdY1SGuge3xgR6qIhNYxUPOxA+TZtLE=";
   };
 
   postPatch = ''
     # disable gradle plugins with native code and their targets
     perl -i.bak1 -pe "s#(^\s*id '.+' version '.+'$)#// \1#" build.gradle
-    perl -i.bak2 -pe "s#(.*)#// \1# if /^(buildscript|task portable|task nsis|task proguard|task tgz|task\(afterEclipseImport\)|launch4j|macAppBundle|buildRpm|buildDeb|shadowJar)/ ... /^}/" build.gradle
-    # Remove unbuildable android stuff
-    rm android/build.gradle
+    perl -i.bak2 -pe "s#(.*)#// \1# if /^(buildscript|task portable|task nsis|task proguard|task tgz|task\(afterEclipseImport\)|launch4j|macAppBundle|buildRpm|buildDeb|shadowJar|robovm)/ ... /^}/" build.gradle
+    # Remove unbuildable Android/iOS stuff
+    rm android/build.gradle ios/build.gradle
   '';
 
   # fake build to pre-download deps into fixed-output derivation
@@ -46,9 +46,8 @@ let
         | perl -pe 's#(.*/([^/]+)/([^/]+)/([^/]+)/[0-9a-f]{30,40}/([^/\s]+))$# ($x = $2) =~ tr|\.|/|; "install -Dm444 $1 \$out/$x/$3/$4/$5" #e' \
         | sh
     '';
-    outputHashAlgo = "sha256";
     outputHashMode = "recursive";
-    outputHash = "0ih10c6c85vhrqgilqmkzqjx3dc8cscvs9wkh90zgdj10qv0iba3";
+    outputHash = "sha256-0P/BcjNnbDN25DguRcCyzPuUG7bouxEx1ySodIbSwvg=";
   };
 
 in stdenv.mkDerivation rec {