about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@viric.name>2016-04-16 00:59:45 +0200
committerLluís Batlle i Rossell <viric@viric.name>2016-04-18 12:30:47 +0200
commite741a302d4f71f73475df4081f32ccc5fd4ebf02 (patch)
treec06151dfc9966ff5a187b976b57ef07a58933f27 /pkgs/games
parent93bd5556be976d27128cc8fd99c0a106e82be73f (diff)
downloadnixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar.gz
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar.bz2
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar.lz
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar.xz
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.tar.zst
nixlib-e741a302d4f71f73475df4081f32ccc5fd4ebf02.zip
Make rigsofrods build the latest code.
I add angelscript 2.22 too, as it makes RoR happy.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/rigsofrods/default.nix42
-rw-r--r--pkgs/games/rigsofrods/doubleslash.patch13
-rw-r--r--pkgs/games/rigsofrods/paths.patch12
3 files changed, 22 insertions, 45 deletions
diff --git a/pkgs/games/rigsofrods/default.nix b/pkgs/games/rigsofrods/default.nix
index 26c7e0a36677..04b632e0dd3e 100644
--- a/pkgs/games/rigsofrods/default.nix
+++ b/pkgs/games/rigsofrods/default.nix
@@ -1,15 +1,17 @@
-{ fetchsvn, fetchurl, stdenv, wxGTK29, freeimage, cmake, zziplib, mesa, boost,
+{ fetchurl, fetchFromGitHub, stdenv, wxGTK30, freeimage, cmake, zziplib, mesa, boost,
   pkgconfig, libuuid, openal, ogre, ois, curl, gtk, pixman, mygui, unzip,
-  angelscript, caelum, ogrepaged, mysocketw, libxcb
+  angelscript, ogrepaged, mysocketw, libxcb
   }:
 
 stdenv.mkDerivation rec {
-  version = "0.39.4";
+  version = "git-20160412";
   name = "rigsofrods-${version}";
 
-  src = fetchurl {
-    url = mirror://sourceforge/rigsofrods/rigsofrods-source-0.39.4.tar.bz2;
-    sha256 = "1kpjkski0yllwzdki0rjpqvifjs0fwpgs513y4dv4s9wfwan1qcx";
+  src = fetchFromGitHub {
+    owner = "RigsOfRods";
+    repo = "rigs-of-rods";
+    rev = "1ebd359dbd467b4c3171dd6d054e7d8ec39f78ba";
+    sha256 = "0h71nrgq5r5cnh20c7wl8jzyaf50dj1b5jdrwihnklpsfyfvjlw4";
   };
 
   contentPackSrc = fetchurl {
@@ -19,21 +21,21 @@ stdenv.mkDerivation rec {
 
   enableParallelBuilding = true;
 
-  cmakeFlags = [
-    "-DROR_USE_CURL=TRUE"
-    "-DROR_USE_MYGUI=TRUE"
-    "-DROR_USE_OPNEAL=TRUE"
-    "-DROR_USE_CAELUM=TRUE"
-    "-DROR_USE_PAGED=TRUE"
-    "-DROR_USE_ANGELSCRIPT=TRUE"
-    "-DROR_USE_SOCKETW=TRUE"
-    "-DCMAKE_BUILD_TYPE=Release"
-  ];
+  #cmakeFlags = [
+  #  "-DROR_USE_CURL=TRUE"
+  #  "-DROR_USE_MYGUI=TRUE"
+  #  "-DROR_USE_OPNEAL=TRUE"
+  #  "-DROR_USE_CAELUM=TRUE"
+  #  "-DROR_USE_PAGED=TRUE"
+  #  "-DROR_USE_ANGELSCRIPT=TRUE"
+  #  "-DROR_USE_SOCKETW=TRUE"
+  #  "-DCMAKE_BUILD_TYPE=Release"
+  #];
 
   installPhase = ''
     sed -e "s@/usr/local/lib/OGRE@${ogre}/lib/OGRE@" -i ../tools/linux/binaries/plugins.cfg
     mkdir -p $out/share/rigsofrods
-    cp -r ../bin/* $out/share/rigsofrods
+    cp -r bin/* $out/share/rigsofrods
     cp ../tools/linux/binaries/plugins.cfg $out/share/rigsofrods
     mkdir -p $out/bin
     ln -s $out/share/rigsofrods/{RoR,rorconfig} $out/bin
@@ -43,11 +45,11 @@ stdenv.mkDerivation rec {
     unzip "${contentPackSrc}"
   '';
 
-  patches = [ ./doubleslash.patch ./paths.patch ];
+  #patches = [ ./paths.patch ];
 
-  buildInputs = [ wxGTK29 freeimage cmake zziplib mesa boost pkgconfig
+  buildInputs = [ wxGTK30 freeimage cmake zziplib mesa boost pkgconfig
     libuuid openal ogre ois curl gtk mygui unzip angelscript
-    caelum ogrepaged mysocketw libxcb ];
+    ogrepaged mysocketw libxcb ];
 
   meta = {
     description = "3D simulator game where you can drive, fly and sail various vehicles";
diff --git a/pkgs/games/rigsofrods/doubleslash.patch b/pkgs/games/rigsofrods/doubleslash.patch
deleted file mode 100644
index c62c5470dfc7..000000000000
--- a/pkgs/games/rigsofrods/doubleslash.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeDependenciesConfig.txt b/CMakeDependenciesConfig.txt
-index 447a440..e2562de 100644
---- a/CMakeDependenciesConfig.txt
-+++ b/CMakeDependenciesConfig.txt
-@@ -228,7 +228,7 @@ ELSEIF(UNIX)
-    # Paged Geometry

-    find_path(PAGED_INCLUDE_DIRS "PagedGeometry/PagedGeometry.h")

-    if(PAGED_INCLUDE_DIRS)

--      set(PAGED_INCLUDE_DIRS "${PAGED_INCLUDE_DIRS};/${PAGED_INCLUDE_DIRS}/PagedGeometry")

-+      set(PAGED_INCLUDE_DIRS "${PAGED_INCLUDE_DIRS};${PAGED_INCLUDE_DIRS}/PagedGeometry")

-       find_library(PAGED_LIBRARIES "PagedGeometry")

-       set(ROR_USE_PAGED ON)

-    else()

diff --git a/pkgs/games/rigsofrods/paths.patch b/pkgs/games/rigsofrods/paths.patch
deleted file mode 100644
index e20b00a76935..000000000000
--- a/pkgs/games/rigsofrods/paths.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/source/main/framework/ContentManager.cpp b/source/main/framework/ContentManager.cpp
-index 0bfea8c..82cdab9 100644
---- a/source/main/framework/ContentManager.cpp
-+++ b/source/main/framework/ContentManager.cpp
-@@ -238,6 +238,7 @@ bool ContentManager::init(void)
- #endif // USE_OPENAL
- 
- 	// and the content
-+	ResourceGroupManager::getSingleton().addResourceLocation(SSETTING("Program Path")+"packs", "FileSystem", "Packs", true);
- 	ResourceGroupManager::getSingleton().addResourceLocation(SSETTING("User Path")+"packs", "FileSystem", "Packs", true);
- 	ResourceGroupManager::getSingleton().addResourceLocation(SSETTING("User Path")+"mods",  "FileSystem", "Packs", true);
-