about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSergei Trofimovich <slyich@gmail.com>2022-03-06 08:52:54 +0000
committerSergei Trofimovich <slyich@gmail.com>2022-03-06 08:52:54 +0000
commite545a7796b437ae13d21ac1655b984e844b4a570 (patch)
tree429c9a781fe72f68ff8c53e543ad85f16c4c36e4 /pkgs/games
parent194b1de4e798d783a52d48fa633de869a199d29f (diff)
downloadnixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar.gz
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar.bz2
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar.lz
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar.xz
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.tar.zst
nixlib-e545a7796b437ae13d21ac1655b984e844b4a570.zip
ufoai: fix underlinking against -lm
Without the change build fails as:
    ld: release-linux-x86_64/testall/client/sound/s_mix.c.o: undefined reference to symbol 'acos@@GLIBC_2.2.5'

With change added I was able to start ufoai.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/ufoai/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/pkgs/games/ufoai/default.nix b/pkgs/games/ufoai/default.nix
index 89f8f5ec91bf..1dc2abbf7624 100644
--- a/pkgs/games/ufoai/default.nix
+++ b/pkgs/games/ufoai/default.nix
@@ -24,7 +24,13 @@ stdenv.mkDerivation rec {
     curl libjpeg libpng gettext cunit
   ];
 
-  NIX_CFLAGS_LINK = "-lgcc_s"; # to avoid occasional runtime error in finding libgcc_s.so.1
+  NIX_CFLAGS_LINK = [
+    # to avoid occasional runtime error in finding libgcc_s.so.1
+    "-lgcc_s"
+    # tests are underlinked against libm:
+    # ld: release-linux-x86_64/testall/client/sound/s_mix.c.o: undefined reference to symbol 'acos@@GLIBC_2.2.5'
+    "-lm"
+  ];
 
   meta = {
     homepage = "http://ufoai.org";