about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2017-05-06 18:16:06 +0100
committerGitHub <noreply@github.com>2017-05-06 18:16:06 +0100
commitdf5329e12758071cf0a4e2c5932b3c5db3754ef8 (patch)
tree1e1fe57ad62734cfa012995fa35cb5633be3d45f /pkgs/games
parent1035af4789beaac0110dab6da005ef037bd5231e (diff)
parent7c955abfc4ea4ae83428bf1813f003ea5a6591b9 (diff)
downloadnixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar.gz
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar.bz2
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar.lz
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar.xz
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.tar.zst
nixlib-df5329e12758071cf0a4e2c5932b3c5db3754ef8.zip
Merge pull request #20317 from Radvendii/master
MAR1D: init at 0.2.0
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/mar1d/default.nix69
1 files changed, 69 insertions, 0 deletions
diff --git a/pkgs/games/mar1d/default.nix b/pkgs/games/mar1d/default.nix
new file mode 100644
index 000000000000..5494e32b16b6
--- /dev/null
+++ b/pkgs/games/mar1d/default.nix
@@ -0,0 +1,69 @@
+{ stdenv
+, fetchFromGitHub
+, cmake
+, mesa_glu
+, x11
+, xorg
+, xinput_calibrator
+, doxygen
+, libpthreadstubs
+, alsaLib
+, alsaOss
+, libao
+, width ? 30
+, mute ? false
+, effects ? false
+, sensitivity ? 5
+, reverseY ? false
+}:
+
+stdenv.mkDerivation rec {
+  name = "MAR1D-${version}";
+  version = "0.2.0";
+  options = "-w${toString width}"
+          + " -s${toString sensitivity}"
+          + (if mute then " -m" else "")
+          + (if effects then " -f" else "")
+          + (if reverseY then " -r" else "");
+
+  src = fetchFromGitHub {
+    sha256 = "152w5dnlxzv60cl24r5cmrj2q5ar0jiimrmxnp87kf4d2dpbnaq7";
+    rev = "v${version}";
+    repo = "fp_mario";
+    owner = "olynch";
+  };
+
+  buildInputs =
+    [
+      alsaLib
+      alsaOss
+      cmake
+      doxygen
+      libao
+      libpthreadstubs
+      mesa_glu
+      x11
+      xinput_calibrator
+      xorg.libXrandr
+      xorg.libXi
+      xorg.xinput
+    ];
+
+  preConfigure = ''
+    cd src
+  '';
+
+  meta = with stdenv.lib; {
+    description = "First person Super Mario Bros";
+    longDescription = ''
+      The original Super Mario Bros as you've never seen it. Step into Mario's
+      shoes in this first person clone of the classic Mario game. True to the
+      original, however, the game still takes place in a two dimensional world.
+      You must view the world as mario does, as a one dimensional line.
+    '';
+    homepage = https://github.com/olynch/fp_mario;
+    license = licenses.agpl3;
+    maintainers = with maintainers; [ taeer ];
+    platforms = platforms.linux;
+  };
+}