about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorseth <getchoo@tuta.io>2023-09-29 17:04:34 -0400
committerseth <getchoo@tuta.io>2023-09-29 17:14:17 -0400
commitcd1310ab07e9dad118bb2a77661f503cae55a99e (patch)
tree6ecdd5772cb895537ffaa860b246d1a6270ce7d0 /pkgs/games
parent69a3d7e4b36febf6ebdd2398a4516524e25c176b (diff)
downloadnixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar.gz
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar.bz2
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar.lz
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar.xz
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.tar.zst
nixlib-cd1310ab07e9dad118bb2a77661f503cae55a99e.zip
prismlauncher: use addOpenGLRunpath.driverLink in wrapper
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/prismlauncher/wrapper.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/games/prismlauncher/wrapper.nix b/pkgs/games/prismlauncher/wrapper.nix
index c95a5c00bcf0..4b0aa418fb6a 100644
--- a/pkgs/games/prismlauncher/wrapper.nix
+++ b/pkgs/games/prismlauncher/wrapper.nix
@@ -3,6 +3,7 @@
 , symlinkJoin
 , prismlauncher-unwrapped
 , wrapQtAppsHook
+, addOpenGLRunpath
 , qtbase  # needed for wrapQtAppsHook
 , qtsvg
 , qtwayland
@@ -85,7 +86,7 @@ symlinkJoin {
     in
     [ "--prefix PRISMLAUNCHER_JAVA_PATHS : ${lib.makeSearchPath "bin/java" jdks}" ]
     ++ lib.optionals stdenv.isLinux [
-      "--set LD_LIBRARY_PATH /run/opengl-driver/lib:${lib.makeLibraryPath runtimeLibs}"
+      "--set LD_LIBRARY_PATH ${addOpenGLRunpath.driverLink}/lib:${lib.makeLibraryPath runtimeLibs}"
       # xorg.xrandr needed for LWJGL [2.9.2, 3) https://github.com/LWJGL/lwjgl/issues/128
       "--prefix PATH : ${lib.makeBinPath runtimePrograms}"
     ];