about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2019-06-19 14:23:31 +0200
committerGitHub <noreply@github.com>2019-06-19 14:23:31 +0200
commitc33153bf1395e1149bf018ea391977b0ae399dde (patch)
tree030fb5d077f9942f9c9181b9b72d3079bb124128 /pkgs/games
parent56cc1e3aca3d877c3cab4f2d5b170245470deb46 (diff)
parent671e53af6736630cad70e8c404f263c8720ae3a1 (diff)
downloadnixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar.gz
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar.bz2
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar.lz
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar.xz
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.tar.zst
nixlib-c33153bf1395e1149bf018ea391977b0ae399dde.zip
Merge pull request #63108 from Shados/lua-packaging-improvements-pr
Lua/luarocks packaging improvements
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/mudlet/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/games/mudlet/default.nix b/pkgs/games/mudlet/default.nix
index 673efb0e118d..dab83ddc900d 100644
--- a/pkgs/games/mudlet/default.nix
+++ b/pkgs/games/mudlet/default.nix
@@ -1,5 +1,5 @@
 { fetchurl, unzip, stdenv, makeWrapper, qtbase, yajl, libzip, hunspell
-, boost, lua5_1, luafilesystem, luazip, lrexlib, luasqlite3, qmake }:
+, boost, lua5_1, luafilesystem, luazip, lrexlib-pcre, luasql-sqlite3, qmake }:
 
 stdenv.mkDerivation rec {
   name = "mudlet-${version}";
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ makeWrapper qmake ];
   buildInputs = [
     unzip qtbase lua5_1 hunspell libzip yajl boost
-    luafilesystem luazip lrexlib luasqlite3
+    luafilesystem luazip lrexlib-pcre luasql-sqlite3
   ];
 
   preConfigure = "cd src";
@@ -21,8 +21,8 @@ stdenv.mkDerivation rec {
   installPhase = let
     luaZipPath = "${luazip}/lib/lua/5.1/?.so";
     luaFileSystemPath = "${luafilesystem}/lib/lua/5.1/?.so";
-    lrexlibPath = "${lrexlib}/lib/lua/5.1/?.so";
-    luasqlitePath = "${luasqlite3}/lib/lua/5.1/?.so";
+    lrexlibPath = "${lrexlib-pcre}/lib/lua/5.1/?.so";
+    luasqlitePath = "${luasql-sqlite3}/lib/lua/5.1/?.so";
   in ''
     mkdir -pv $out/bin
     cp mudlet $out