about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSarah Brofeldt <sbrofeldt@gmail.com>2018-12-13 12:13:35 +0100
committerGitHub <noreply@github.com>2018-12-13 12:13:35 +0100
commitb64e71e09cf8df9f5b70a04e87dde9f88fe2a773 (patch)
tree8f17b6f360647a1e56e4205da6b78be4daf52a95 /pkgs/games
parent40c02415ae952ce1a2f0853cec8eb09c587084a3 (diff)
parentcd075e50452a9214a3e7527c958ea0d81ca6bf64 (diff)
downloadnixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar.gz
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar.bz2
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar.lz
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar.xz
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.tar.zst
nixlib-b64e71e09cf8df9f5b70a04e87dde9f88fe2a773.zip
Merge pull request #51677 from plapadoo/pro-office-calculator-init
pro-office-calculator: init at 1.0.6
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/pro-office-calculator/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/games/pro-office-calculator/default.nix b/pkgs/games/pro-office-calculator/default.nix
new file mode 100644
index 000000000000..f7eebea75630
--- /dev/null
+++ b/pkgs/games/pro-office-calculator/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, tinyxml-2, cmake, qtbase, qtmultimedia, fetchpatch }:
+stdenv.mkDerivation rec {
+  version = "1.0.6";
+  name = "pro-office-calculator-${version}";
+
+  src = fetchFromGitHub {
+    owner  = "RobJinman";
+    repo   = "pro_office_calc";
+    rev    = "v${version}";
+    sha256 = "1irgch6cbc2f8il1zh8qf98m43h41hma80dxzz9c7xvbvl99lybd";
+  };
+
+  buildInputs = [ qtbase qtmultimedia tinyxml-2 ];
+
+  # This fixes a bug resulting in "illegal instruction"
+  patches = [(fetchpatch {
+    url = https://github.com/RobJinman/pro_office_calc/commit/806180d69d4af6b3183873f471c57bfdaf529560.patch;
+    sha256 = "1rcdjy233yf3kv4v18c82jyg08dykj2qspvg08n5b3bir870sbxz";
+  })];
+
+  nativeBuildInputs = [ cmake ];
+
+  meta = with stdenv.lib; {
+    description = "Just an ordinary calculator. Nothing to see here...";
+    homepage = http://proofficecalculator.com/;
+    maintainers = [ maintainers.pmiddend ];
+    platforms = platforms.linux;
+    license = licenses.gpl3;
+  };
+}