about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTom Hall <tahall256@protonmail.ch>2020-06-08 19:50:52 +0100
committerTom Hall <tahall256@protonmail.ch>2020-06-14 23:22:40 +0100
commitb5bb2015795e6bee3d87f81eb406caedd991e903 (patch)
treea1bc2b4bfca2659e10f3d3f9aa52ac304b17e9c7 /pkgs/games
parent731f722289f4beebbd2cf884156388ecfe28da1e (diff)
downloadnixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar.gz
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar.bz2
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar.lz
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar.xz
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.tar.zst
nixlib-b5bb2015795e6bee3d87f81eb406caedd991e903.zip
augustus: init at 1.4.1a
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/augustus/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/games/augustus/default.nix b/pkgs/games/augustus/default.nix
new file mode 100644
index 000000000000..cabe419ef5bc
--- /dev/null
+++ b/pkgs/games/augustus/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchFromGitHub, cmake, SDL2, SDL2_mixer, libpng }:
+
+stdenv.mkDerivation rec {
+  pname = "augustus";
+  version = "1.4.1a";
+
+  src = fetchFromGitHub {
+    owner = "Keriew";
+    repo = "augustus";
+    rev = "v${version}";
+    sha256 = "1xqv8j8jh3f13fjhyf7hk1anrn799cwwsvsd75kpl9n5yh5s1j5y";
+  };
+
+  nativeBuildInputs = [ cmake ];
+  buildInputs = [ SDL2 SDL2_mixer libpng ];
+
+  meta = with stdenv.lib; {
+    description = "An open source re-implementation of Caesar III. Fork of Julius incorporating gameplay changes";
+    homepage = "https://github.com/Keriew/augustus";
+    license = licenses.agpl3;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ Thra11 ];
+  };
+}