about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorEmery Hemingway <ehmry@posteo.net>2022-07-11 18:23:52 -0500
committerehmry <ehmry@posteo.net>2022-08-19 13:11:27 -0500
commitb5526585c2de2e66c9111a5484dee65806acbcf5 (patch)
tree72625ad307637114914f9266658d7ad78e52c785 /pkgs/games
parent1a9c66f883bd8ccd71279a7faabe1a5556b9ccb2 (diff)
downloadnixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar.gz
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar.bz2
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar.lz
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar.xz
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.tar.zst
nixlib-b5526585c2de2e66c9111a5484dee65806acbcf5.zip
treewide: inject xdg-open into wrappers as $PATH suffix
The xdg-open utility is only ever a runtime dependency and its
dependents only expect that it accept a URI as a command line
argument and do something with it that the user would expect.
For such as a trivial relationship it should be possible for
users to override xdg-open with something else in their PATH.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/enigma/default.nix3
-rw-r--r--pkgs/games/grapejuice/default.nix4
2 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/games/enigma/default.nix b/pkgs/games/enigma/default.nix
index 247d7b9dee19..c9f16918b490 100644
--- a/pkgs/games/enigma/default.nix
+++ b/pkgs/games/enigma/default.nix
@@ -31,7 +31,8 @@ stdenv.mkDerivation rec {
 
   postInstall = ''
     rm -r $out/include
-    wrapProgram $out/bin/enigma --prefix PATH : "${lib.makeBinPath [ xdg-utils ]}"
+    # make xdg-open overrideable at runtime
+    wrapProgram $out/bin/enigma --suffix PATH : "${lib.makeBinPath [ xdg-utils ]}"
   '';
 
   meta = with lib; {
diff --git a/pkgs/games/grapejuice/default.nix b/pkgs/games/grapejuice/default.nix
index 23e245149ad7..24835f604ae3 100644
--- a/pkgs/games/grapejuice/default.nix
+++ b/pkgs/games/grapejuice/default.nix
@@ -56,7 +56,9 @@ python3Packages.buildPythonApplication rec  {
 
   makeWrapperArgs = [
     "\${gappsWrapperArgs[@]}"
-    "--prefix PATH : ${lib.makeBinPath [ xdg-user-dirs xdg-utils wine winetricks pciutils glxinfo ]}"
+    "--prefix PATH : ${lib.makeBinPath [ xdg-user-dirs wine winetricks pciutils glxinfo ]}"
+    # make xdg-open overrideable at runtime
+    "--suffix PATH : ${lib.makeBinPath [ xdg-utils ]}"
   ];
 
   postPatch = ''