about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2015-09-11 02:25:52 +0300
committerMichael Raskin <7c6f434c@mail.ru>2015-09-11 02:26:09 +0300
commitb1acfea179e22a24fa7bfd5f53166f2b5973dfa0 (patch)
treea8671dac425c21411ccce40524310d7712a5b452 /pkgs/games
parent8b297075924321e4aeb7ce2f694ccec69ccfb90e (diff)
downloadnixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar.gz
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar.bz2
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar.lz
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar.xz
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.tar.zst
nixlib-b1acfea179e22a24fa7bfd5f53166f2b5973dfa0.zip
Blood's Pilot (another XPilot fork): init at 1.4.6 server/1.5.0 client
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/xpilot/bloodspilot-client.nix24
-rw-r--r--pkgs/games/xpilot/bloodspilot-server.nix23
2 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/games/xpilot/bloodspilot-client.nix b/pkgs/games/xpilot/bloodspilot-client.nix
new file mode 100644
index 000000000000..e93d9cab3525
--- /dev/null
+++ b/pkgs/games/xpilot/bloodspilot-client.nix
@@ -0,0 +1,24 @@
+{stdenv, fetchurl, libX11, SDL, mesa, expat, SDL_ttf, SDL_image}:
+let
+  buildInputs = [
+    libX11 SDL SDL_ttf SDL_image mesa expat
+  ];
+in
+stdenv.mkDerivation rec {
+  version = "1.5.0";
+  name = "bloodspilot-client-${version}";
+  inherit buildInputs;
+  src = fetchurl {
+    url = "mirror://sourceforge/project/bloodspilot/client-sdl/v${version}/bloodspilot-client-sdl-${version}.tar.gz";
+    sha256 = "1qwl95av5an2zl01m7saj6fyy49xpixga7gbn4lwbpgpqs1rbwxj";
+  };
+  NIX_LDFLAGS=["-lX11"];
+  meta = {
+    inherit version;
+    description = ''A multiplayer space combat game (client part)'';
+    homepage = "http://bloodspilot.sf.net/";
+    license = stdenv.lib.licenses.gpl2Plus ;
+    maintainers = [stdenv.lib.maintainers.raskin];
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
diff --git a/pkgs/games/xpilot/bloodspilot-server.nix b/pkgs/games/xpilot/bloodspilot-server.nix
new file mode 100644
index 000000000000..3c811f1ba2ef
--- /dev/null
+++ b/pkgs/games/xpilot/bloodspilot-server.nix
@@ -0,0 +1,23 @@
+{stdenv, fetchurl, expat}:
+let
+  buildInputs = [
+    expat
+  ];
+in
+stdenv.mkDerivation rec {
+  version = "1.4.6";
+  name = "bloodspilot-xpilot-fxi-server-${version}";
+  inherit buildInputs;
+  src = fetchurl {
+    url = "mirror://sourceforge/project/bloodspilot/server/server%20v${version}/xpilot-${version}fxi.tar.gz";
+    sha256 = "0d7hnpshifq6gy9a0g6il6h1hgqqjyys36n8w84hr8d4nhg4d1ji";
+  };
+  meta = {
+    inherit version;
+    description = ''A multiplayer X11 space combat game (server part)'';
+    homepage = "http://bloodspilot.sf.net/";
+    license = stdenv.lib.licenses.gpl2Plus ;
+    maintainers = [stdenv.lib.maintainers.raskin];
+    platforms = stdenv.lib.platforms.linux;
+  };
+}