about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJoachim Schiele <js@lastlog.de>2012-03-09 00:59:13 +0000
committerJoachim Schiele <js@lastlog.de>2012-03-09 00:59:13 +0000
commitac9f3a50a22a72bb554cb6b9192fc6a46bfffff7 (patch)
treefd8261c5571dbd6081b57c79442f709f71c19d8b /pkgs/games
parenta14e9f7c0f8dc36f86e85ece13013247e5c78f81 (diff)
downloadnixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar.gz
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar.bz2
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar.lz
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar.xz
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.tar.zst
nixlib-ac9f3a50a22a72bb554cb6b9192fc6a46bfffff7.zip
package won't build on the current nixos/nixpkgs (but it did with older checkouts on my other computer). so here is a fix which makes springlobby compile and install at least
svn path=/nixpkgs/trunk/; revision=32937
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/spring/springlobby.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/games/spring/springlobby.nix b/pkgs/games/spring/springlobby.nix
index 29ef95588193..06c98411f5b4 100644
--- a/pkgs/games/spring/springlobby.nix
+++ b/pkgs/games/spring/springlobby.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, cmake, wxGTK, openal, pkgconfig, curl, libtorrentRasterbar
-, gettext, bash, gawk, boost }:
+, gettext, bash, gawk, boost}:
 stdenv.mkDerivation rec {
 
   name = "springlobby-${version}";
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
     sha256 = "37cf3aa1ed78a0ded782cc5c692301619dbb2cf4749bccbf059c51707daaf734";
   };
 
-  buildInputs = [ cmake wxGTK openal pkgconfig curl gettext libtorrentRasterbar boost ];
+  buildInputs = [ cmake wxGTK openal pkgconfig curl gettext libtorrentRasterbar boost];
 
   prePatch = ''
     substituteInPlace tools/regen_config_header.sh --replace "#!/usr/bin/env bash" "#!${bash}/bin/bash"
@@ -18,8 +18,13 @@ stdenv.mkDerivation rec {
     substituteInPlace CMakeLists.txt --replace "boost_system-mt" "boost_system"
   '';
 
+  # for now sound is disabled as it causes a linker error with alure i can't resolve (qknight)
+  cmakeFlags = "-DOPTION_SOUND:BOOL=OFF"; 
+
   enableParallelBuilding = true;
 
+  #buildPhase = "make VERBOSE=1";
+
   meta = with stdenv.lib; {
     homepage = http://springlobby.info/;
     description = "A free cross-platform lobby client for the Spring RTS project.";