about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorCharlotte Van Petegem <charlotte@vanpetegem.me>2021-03-20 15:34:10 +0100
committerDaniel Nagy <danielnagy@posteo.de>2021-03-20 15:35:17 +0100
commita410e5dc477f4a6c5f1683513b4406ad14d10718 (patch)
tree19a2258ead400db8107e7c3eabfca5e8000ee91d /pkgs/games
parent9815ef3639ac523d077805f211d5b09dccd7f794 (diff)
downloadnixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar.gz
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar.bz2
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar.lz
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar.xz
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.tar.zst
nixlib-a410e5dc477f4a6c5f1683513b4406ad14d10718.zip
zeroad: fix build of spidermonkey derivation
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/0ad/game.nix3
-rw-r--r--pkgs/games/0ad/spidermonkey-cargo-toml.patch15
2 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/games/0ad/game.nix b/pkgs/games/0ad/game.nix
index 3543121071ed..bb3b7c0138af 100644
--- a/pkgs/games/0ad/game.nix
+++ b/pkgs/games/0ad/game.nix
@@ -19,6 +19,9 @@ let
       url = "mirror://mozilla/firefox/releases/${version}esr/source/firefox-${version}esr.source.tar.xz";
       sha256 = "0lyg65v380j8i2lrylwz8a5ya80822l8vcnlx3dfqpd3s6zzjsay";
     };
+    patches = (old.patches or []) ++ [
+      ./spidermonkey-cargo-toml.patch
+    ];
   });
 in
 stdenv.mkDerivation rec {
diff --git a/pkgs/games/0ad/spidermonkey-cargo-toml.patch b/pkgs/games/0ad/spidermonkey-cargo-toml.patch
new file mode 100644
index 000000000000..4cb8c3735dbd
--- /dev/null
+++ b/pkgs/games/0ad/spidermonkey-cargo-toml.patch
@@ -0,0 +1,15 @@
+diff --git a/Cargo.toml b/Cargo.toml
+index 6f6199ab26..c3f92db9d8 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -68,8 +68,8 @@ panic = "abort"
+ libudev-sys = { path = "dom/webauthn/libudev-sys" }
+ packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="3541e3818fdc7c2a24f87e3459151a4ce955a67a" }
+ rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
+-nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
+-spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
++nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1" }
++spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
+ # failure's backtrace feature might break our builds, see bug 1608157.
+ failure = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }
+ failure_derive = { git = "https://github.com/badboy/failure", rev = "64af847bc5fdcb6d2438bec8a6030812a80519a5" }