about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-06-03 12:03:00 +0200
committerGitHub <noreply@github.com>2021-06-03 12:03:00 +0200
commit9a5a63960822648d82974067925d8f1c0b944be4 (patch)
treea1871a6ae110855bb150475c53b9fe5b5ad021ea /pkgs/games
parent856363d6db1fea491add0067b5ef2f88059e0a7d (diff)
parent39a94997742d1c47d7880b223a232f1f0c39f994 (diff)
downloadnixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar.gz
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar.bz2
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar.lz
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar.xz
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.tar.zst
nixlib-9a5a63960822648d82974067925d8f1c0b944be4.zip
Merge pull request #125006 from astro/frogatto
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/frogatto/data.nix6
-rw-r--r--pkgs/games/frogatto/default.nix1
-rw-r--r--pkgs/games/frogatto/engine.nix12
3 files changed, 11 insertions, 8 deletions
diff --git a/pkgs/games/frogatto/data.nix b/pkgs/games/frogatto/data.nix
index e911709dffcc..d31826ad2959 100644
--- a/pkgs/games/frogatto/data.nix
+++ b/pkgs/games/frogatto/data.nix
@@ -2,14 +2,14 @@
 
 stdenv.mkDerivation {
   pname = "frogatto-data";
-  version = "unstable-2018-12-18";
+  version = "unstable-2021-05-24";
 
   src = fetchFromGitHub {
     owner = "frogatto";
     repo = "frogatto";
     # master branch as of 2020-12-17
-    rev = "c1d0813b3b755a4e232369b6791397ad058efc16";
-    sha256 = "1fhaidd35392zzavp93r6ihyansgkc3m1ilz71ia1zl4n3fbsxjg";
+    rev = "8b0f2bc8f9f172f6225b8e0d806552cb94f35e2a";
+    sha256 = "09nrna9l1zj2ma2bazdhdvphwy570kfz4br4xgpwq21rsjrvrqiy";
   };
 
   installPhase = ''
diff --git a/pkgs/games/frogatto/default.nix b/pkgs/games/frogatto/default.nix
index 69d5282aedca..0b53e3d0bea3 100644
--- a/pkgs/games/frogatto/default.nix
+++ b/pkgs/games/frogatto/default.nix
@@ -34,7 +34,6 @@ in buildEnv {
   '';
 
   meta = with lib; {
-    broken = true;
     homepage = "https://frogatto.com";
     description = description;
     license = with licenses; [ cc-by-30 unfree ];
diff --git a/pkgs/games/frogatto/engine.nix b/pkgs/games/frogatto/engine.nix
index 4ebf22b46b0e..22aab537c217 100644
--- a/pkgs/games/frogatto/engine.nix
+++ b/pkgs/games/frogatto/engine.nix
@@ -4,17 +4,21 @@
 
 stdenv.mkDerivation {
   pname = "anura-engine";
-  version = "unstable-2018-11-28";
+  version = "unstable-2021-05-24";
 
   src = fetchFromGitHub {
     owner = "anura-engine";
     repo = "anura";
-    # trunk branch as of 2018-11-28
-    rev = "a05f413f255d2854019134be817c253a03da3d9f";
-    sha256 = "1hd57q8gbn1zdpibnqd3ma0z1ycayc2f4r9j4m2m9kc6yf4v7w7b";
+    rev = "ed50bbfa68a4aa09438d95d39103ec39156d438f";
+    sha256 = "0bk0qklk9wwx3jr2kbrmansccn1nj962v5n2vlb5hxsrcv96s3dg";
     fetchSubmodules = true;
   };
 
+  postPatch = ''
+    substituteInPlace src/sys.cpp \
+      --replace mallinfo2 mallinfo
+  '';
+
   nativeBuildInputs = [
     which pkg-config
   ];