about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-06-05 20:45:29 +0200
committerGitHub <noreply@github.com>2021-06-05 20:45:29 +0200
commit929c876f65172b8e50084b1e6b446f4b7e6f4dbd (patch)
treec565cc63d978e78f974cb320f1bea3db6bda205b /pkgs/games
parent157aee00a5b599027f5daa90b699735441ace1c8 (diff)
parente1b8ef38eae3c562895229a75d075e460461414a (diff)
downloadnixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar.gz
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar.bz2
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar.lz
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar.xz
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.tar.zst
nixlib-929c876f65172b8e50084b1e6b446f4b7e6f4dbd.zip
Merge pull request #125654 from karolchmist/init-fheroes2-0.9.4
fheroes2: init at 0.9.4
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/fheroes2/default.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/games/fheroes2/default.nix b/pkgs/games/fheroes2/default.nix
new file mode 100644
index 000000000000..b9802bd81b5f
--- /dev/null
+++ b/pkgs/games/fheroes2/default.nix
@@ -0,0 +1,45 @@
+{ stdenv, lib, fetchFromGitHub
+, gettext, libpng, SDL2, SDL2_image, SDL2_mixer, SDL2_ttf, zlib
+}:
+
+stdenv.mkDerivation rec {
+  pname = "fheroes2";
+  version = "0.9.4";
+
+  src = fetchFromGitHub {
+    owner = "ihhub";
+    repo = "fheroes2";
+    rev = version;
+    sha256 = "sha256-z+88tVsf4uyMFzNfZDKXo0cYqBCYn1ehX+A+e+aIfSg=";
+  };
+
+  buildInputs = [ gettext libpng SDL2 SDL2_image SDL2_mixer SDL2_ttf zlib ];
+
+  makeFlags = [
+    "FHEROES2_STRICT_COMPILATION=1"
+    "RELEASE=1"
+  ];
+
+  enableParallelBuilding = true;
+
+  installPhase = ''
+    runHook preInstall
+
+    install -Dm755 $PWD/src/dist/fheroes2 $out/bin/fheroes2
+
+    runHook postInstall
+  '';
+
+  meta = with lib; {
+    homepage = "https://github.com/ihhub/fheroes2";
+    description = "Free implementation of Heroes of Might and Magic II game engine";
+    longDescription = ''
+        In order to play this game, an original game data is required.
+        Please refer to README of the project for instructions.
+        On linux, the data can be placed in ~/.local/share/fheroes2 folder.
+    '';
+    license = licenses.gpl2Plus;
+    maintainers = [ maintainers.karolchmist ];
+    platforms = platforms.linux;
+  };
+}