about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2024-01-16 20:02:26 +0100
committerGitHub <noreply@github.com>2024-01-16 20:02:26 +0100
commit8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e (patch)
treeca97d3602c88fc3f69af2901ea05d22596a42479 /pkgs/games
parentacfe2c0f6c27f27dc6266f197a76d6a8806f57d2 (diff)
parent1d7100a082dffe49d94f1afe26be484cd07e3c6f (diff)
downloadnixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar.gz
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar.bz2
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar.lz
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar.xz
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.tar.zst
nixlib-8f0d95b973f66c3b3026913cc9e8d1c0f7f6a28e.zip
Merge pull request #280626 from raphaelr/gcc-libxml-double-trouble
zeroad: fix build with new gcc and libxml
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/0ad/game.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/pkgs/games/0ad/game.nix b/pkgs/games/0ad/game.nix
index 1738c26659d2..eadb8bd27457 100644
--- a/pkgs/games/0ad/game.nix
+++ b/pkgs/games/0ad/game.nix
@@ -55,7 +55,24 @@ stdenv.mkDerivation rec {
     "-L${nvidia-texture-tools.lib}/lib/static"
   ];
 
-  patches = [ ./rootdir_env.patch ];
+  patches = [
+    ./rootdir_env.patch
+
+    # Fix build with libxml v2.12
+    # FIXME: Remove with next package update
+    (fetchpatch {
+      name = "libxml-2.12-fix.patch";
+      url = "https://github.com/0ad/0ad/commit/d242631245edb66816ef9960bdb2c61b68e56cec.patch";
+      hash = "sha256-Ik8ThkewB7wyTPTI7Y6k88SqpWUulXK698tevfSBr6I=";
+    })
+    # Fix build with GCC 13
+    # FIXME: Remove with next package update
+    (fetchpatch {
+      name = "gcc-13-fix.patch";
+      url = "https://github.com/0ad/0ad/commit/093e1eb23519ab4a4633a999a555a58e4fd5343e.patch";
+      hash = "sha256-NuWO64narU1JID/F3cj7lJKjo96XR7gSW0w8I3/hhuw=";
+    })
+  ];
 
   configurePhase = ''
     # Delete shipped libraries which we don't need.