about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorStefan Frijters <sfrijters@gmail.com>2020-06-04 21:39:41 +0200
committerJon <jonringer@users.noreply.github.com>2020-06-04 15:38:08 -0700
commit87dc127ce347020a81b08cdfe66912da14e0dc22 (patch)
tree61a494d29ddded60be09cfc2bfdc50c2ee43e524 /pkgs/games
parentd67e2a27020c373c9bb420bd1e2bf5feef02c135 (diff)
downloadnixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar.gz
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar.bz2
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar.lz
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar.xz
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.tar.zst
nixlib-87dc127ce347020a81b08cdfe66912da14e0dc22.zip
openttd: 1.10.1 -> 1.10.2
A bug in the upstream configure script was fixed (OpenTTD/OpenTTD#8145),
which means we now need `which` available during the build.
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/openttd/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/games/openttd/default.nix b/pkgs/games/openttd/default.nix
index 519d4e3a7419..223f0a6ae8c5 100644
--- a/pkgs/games/openttd/default.nix
+++ b/pkgs/games/openttd/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, fetchzip, pkgconfig, SDL2, libpng, zlib, xz, freetype, fontconfig, libxdg_basedir
+{ stdenv, fetchurl, fetchzip, pkgconfig, which, SDL2, libpng, zlib, xz, freetype, fontconfig, libxdg_basedir
 , withOpenGFX ? true, withOpenSFX ? true, withOpenMSX ? true
 , withFluidSynth ? true, audioDriver ? "alsa", fluidsynth, soundfont-fluid, procps
 , writeScriptBin, makeWrapper, runtimeShell
@@ -29,14 +29,14 @@ let
 in
 stdenv.mkDerivation rec {
   pname = "openttd";
-  version = "1.10.1";
+  version = "1.10.2";
 
   src = fetchurl {
     url = "https://cdn.openttd.org/openttd-releases/${version}/${pname}-${version}-source.tar.xz";
-    sha256 = "0d22a3c50f7a321f4f211594f4987ac16c381e8e3e40f116848e63e91e7fbb9b";
+    sha256 = "1xdn9rr858nq22a13cpbhcw74bwygf7lw95kvx3wn4zvb795b74k";
   };
 
-  nativeBuildInputs = [ pkgconfig makeWrapper ];
+  nativeBuildInputs = [ pkgconfig which makeWrapper ];
   buildInputs = [ SDL2 libpng xz zlib freetype fontconfig libxdg_basedir ]
     ++ stdenv.lib.optionals withFluidSynth [ fluidsynth soundfont-fluid ];