about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2017-11-25 14:51:29 +0000
committerGitHub <noreply@github.com>2017-11-25 14:51:29 +0000
commit86278597936cc35743c3b8a41e2f16f9005b209c (patch)
treec885150dc095b245b22883998952df13f82aa517 /pkgs/games
parentbd1864aec907e149c2295cad3cd5c0813e9c4f0a (diff)
parentc09608f6a8a51e16a3be55626931066a73ef2593 (diff)
downloadnixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar.gz
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar.bz2
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar.lz
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar.xz
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.tar.zst
nixlib-86278597936cc35743c3b8a41e2f16f9005b209c.zip
Merge pull request #31994 from kierdavis/freesweep
freesweep: init at 1.0.1
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/freesweep/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/games/freesweep/default.nix b/pkgs/games/freesweep/default.nix
new file mode 100644
index 000000000000..9d07eda74b81
--- /dev/null
+++ b/pkgs/games/freesweep/default.nix
@@ -0,0 +1,35 @@
+{ fetchurl, ncurses, stdenv,
+  updateAutotoolsGnuConfigScriptsHook }:
+
+stdenv.mkDerivation rec {
+  name = "freesweep-${version}";
+  version = "1.0.1";
+
+  src = fetchurl {
+    url = "https://github.com/rwestlund/freesweep/archive/v${version}.tar.gz";
+    sha256 = "0l2kf14558lsq9qd2hs0kcyn9bbl1jdbzwrvcs6mnyjl7zpizcpj";
+  };
+
+  nativeBuildInputs = [ updateAutotoolsGnuConfigScriptsHook ];
+  buildInputs = [ ncurses ];
+
+  preConfigure = ''
+    configureFlags="$configureFlags --with-prefsdir=$out/share"
+  '';
+
+  installPhase = ''
+    runHook preInstall
+    install -D -m 0555 freesweep $out/bin/freesweep
+    install -D -m 0444 sweeprc $out/share/sweeprc
+    install -D -m 0444 freesweep.6 $out/share/man/man6/freesweep.6
+    runHook postInstall
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A console minesweeper-style game written in C for Unix-like systems";
+    homepage = https://github.com/rwestlund/freesweep;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ kierdavis ];
+    platforms = platforms.unix;
+  };
+}