about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-11-29 19:36:25 -0600
committerGitHub <noreply@github.com>2018-11-29 19:36:25 -0600
commit76c7a8bac083522ea10ba43f699421ca64007708 (patch)
treecc017b17548488b04a0506c1f3c00801839abb75 /pkgs/games
parentf435272ce351ed192e9ff9c643331a4cc063930e (diff)
parentc0a804c747c6909c036da76472393b2fbd6413b9 (diff)
downloadnixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar.gz
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar.bz2
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar.lz
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar.xz
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.tar.zst
nixlib-76c7a8bac083522ea10ba43f699421ca64007708.zip
Merge pull request #51205 from matthewbauer/more-setup-hooks
Add premake & imake setup hook
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/gmad/default.nix2
-rw-r--r--pkgs/games/tome4/default.nix16
-rw-r--r--pkgs/games/xsnow/default.nix18
3 files changed, 10 insertions, 26 deletions
diff --git a/pkgs/games/gmad/default.nix b/pkgs/games/gmad/default.nix
index a15914877ccb..78936ec19499 100644
--- a/pkgs/games/gmad/default.nix
+++ b/pkgs/games/gmad/default.nix
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
     else if stdenv.isDarwin then "gmad_osx"
     else "gmad";
 
-  configurePhase = "premake4 --bootil_lib=${bootil}/lib --bootil_inc=${bootil}/include gmake";
+  premakeFlags = "--bootil_lib=${bootil}/lib --bootil_inc=${bootil}/include";
 
   installPhase = ''
     mkdir -p $out/bin
diff --git a/pkgs/games/tome4/default.nix b/pkgs/games/tome4/default.nix
index 3f6726a17f18..ec529676463f 100644
--- a/pkgs/games/tome4/default.nix
+++ b/pkgs/games/tome4/default.nix
@@ -25,9 +25,10 @@ in stdenv.mkDerivation rec {
     sha256 = "0mc5dgh2x9nbili7gy6srjhb23ckalf08wqq2amyjr5rq392jvd7";
   };
 
-  nativeBuildInputs = [ premake4 makeWrapper unzip ];
+  nativeBuildInputs = [ makeWrapper unzip premake4 ];
 
-  # tome4 vendors quite a few libraries so someone might want to look into avoiding that...
+  # tome4 vendors quite a few libraries so someone might want to look
+  # into avoiding that...
   buildInputs = [
     libGLU openal libpng libvorbis SDL2 SDL2_ttf SDL2_image
   ];
@@ -36,20 +37,11 @@ in stdenv.mkDerivation rec {
   enableParallelBuilding = false;
 
   NIX_CFLAGS_COMPILE = [
+    "-I${SDL2.dev}/include/SDL2"
     "-I${SDL2_image}/include/SDL2"
     "-I${SDL2_ttf}/include/SDL2"
   ];
 
-  postPatch = ''
-    substituteInPlace premake4.lua \
-      --replace "/opt/SDL-2.0/include/SDL2" "${SDL2.dev}/include/SDL2" \
-      --replace "/usr/include/GL" "/run/opengl-driver/include"
-  '';
-
-  preConfigure = ''
-    premake4 gmake
-  '';
-
   makeFlags = [ "config=release" ];
 
   # The wrapper needs to cd into the correct directory as tome4's detection of
diff --git a/pkgs/games/xsnow/default.nix b/pkgs/games/xsnow/default.nix
index 47a321c99b4a..07ed50d4e7b3 100644
--- a/pkgs/games/xsnow/default.nix
+++ b/pkgs/games/xsnow/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, libXt, libXpm, libXext, imake }:
+{ stdenv, fetchurl, libXt, libXpm, libXext, imake, gccmakedep }:
 
 stdenv.mkDerivation rec {
 
@@ -10,25 +10,17 @@ stdenv.mkDerivation rec {
     sha256 = "06jnbp88wc9i9dbmy7kggplw4hzlx2bhghxijmlhkjlizgqwimyh";
   };
 
+  nativeBuildInputs = [ imake gccmakedep ];
   buildInputs = [
-    libXt libXpm libXext imake
+    libXt libXpm libXext
   ];
 
-  buildPhase = ''
-    xmkmf
-    make
-  '';
-
-  installPhase = ''
-    mkdir -p $out/bin $out/share/man/man1
-    cp xsnow $out/bin/
-    cp xsnow.1 $out/share/man/man1/
-  '';
+  makeFlags = [ "BINDIR=$(out)/bin" "MANPATH=$(out)/share/man" ];
 
   meta = {
     description = "An X-windows application that will let it snow on the root, in between and on windows";
     homepage = http://janswaal.home.xs4all.nl/Xsnow/;
     license = stdenv.lib.licenses.unfree;
     maintainers = [ stdenv.lib.maintainers.robberer ];
-  }; 
+  };
 }