about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorGuillaume Bouchard <guillaum.bouchard@gmail.com>2018-03-19 16:04:18 +0100
committerGuillaume Bouchard <guillaum.bouchard@gmail.com>2018-03-31 20:10:51 +0200
commit74de977fddc60aabae391eb1ff4532c5564aaca6 (patch)
tree3d1bf192c22b2b190c94c821fe973ae206de669b /pkgs/games
parent2a0f66b258589f3b58877ad54b8b6082125808a4 (diff)
downloadnixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar.gz
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar.bz2
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar.lz
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar.xz
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.tar.zst
nixlib-74de977fddc60aabae391eb1ff4532c5564aaca6.zip
gcompris: init at 0.90
- uses qt 5.9 (qt 5.10 gives runtime error)
- add a desktop file
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/gcompris/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/games/gcompris/default.nix b/pkgs/games/gcompris/default.nix
new file mode 100644
index 000000000000..89b9fca06eab
--- /dev/null
+++ b/pkgs/games/gcompris/default.nix
@@ -0,0 +1,37 @@
+{stdenv, cmake, qtbase, fetchurl, qtdeclarative, qtmultimedia, qttools, qtsensors, qmlbox2d, gettext, qtquickcontrols, qtgraphicaleffects, makeWrapper,
+  gst_all_1, ninja
+}:
+stdenv.mkDerivation rec {
+  version = "0.90";
+  name = "gcompris-${version}";
+
+  src = fetchurl {
+    url = "http://gcompris.net/download/qt/src/gcompris-qt-${version}.tar.xz";
+    sha256 = "1i5adxnhig849qxwi3c4v7r84q6agx1zxkd69fh4y7lcmq2qiaza";
+  };
+
+  cmakeFlags = "-DQML_BOX2D_LIBRARY=${qmlbox2d}/${qtbase.qtQmlPrefix}/Box2D.2.0";
+
+  nativeBuildInputs = [ cmake ninja makeWrapper ];
+  buildInputs = [ qtbase qtdeclarative qttools qtsensors qmlbox2d gettext qtquickcontrols qtmultimedia qtgraphicaleffects] ++ soundPlugins;
+  soundPlugins = with gst_all_1; [gst-plugins-good gstreamer gst-plugins-base gst-plugins-bad];
+
+  postInstall = ''
+    # install .desktop and icon file
+    mkdir -p $out/share/applications/
+    mkdir -p $out/share/icons/hicolor/256x256/apps/
+    cp ../org.kde.gcompris.desktop $out/share/applications/gcompris.desktop
+    cp -r ../images/256-apps-gcompris-qt.png $out/share/icons/hicolor/256x256/apps/gcompris-qt.png
+
+    wrapProgram "$out/bin/gcompris-qt" \
+       --prefix GST_PLUGIN_SYSTEM_PATH_1_0 : "$GST_PLUGIN_SYSTEM_PATH_1_0"
+    '';
+
+  meta = with stdenv.lib; {
+    description = "A high quality educational software suite, including a large number of activities for children aged 2 to 10";
+    homepage = "https://gcompris.net/";
+    maintainers = [ maintainers.guibou ];
+    platforms = [ "i686-linux" "x86_64-linux" ];
+    license = licenses.gpl3Plus;
+  };
+}