about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTom Fitzhenry <tom@tom-fitzhenry.me.uk>2023-10-06 21:36:48 +1100
committerTom Fitzhenry <tom@tom-fitzhenry.me.uk>2023-10-06 21:36:48 +1100
commit736884108d45daa6c41f123c6b318043a2c33ee1 (patch)
treeff591189833bed68aa8a8c3c771775fde166bfed /pkgs/games
parent51d261b0aed53b56dd4a658a05c9ed6b937eb731 (diff)
downloadnixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar.gz
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar.bz2
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar.lz
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar.xz
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.tar.zst
nixlib-736884108d45daa6c41f123c6b318043a2c33ee1.zip
sgt-puzzles: rename all "sgtpuzzles" -> "sgt-puzzles"
nixpkgs currently mixes sgtpuzzles/sgt-puzzles across filenames,
packages, tests.

This inconsistency is frequently annoying.

Let's unify on "sgt-puzzles", on the basis that:
* "sgt-puzzles" is the package filename.
* Alpine/FreeBSD/Debian use "sgt-puzzles". No other distro uses
"sgtpuzzles". https://repology.org/project/sgt-puzzles/versions
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/sgt-puzzles/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/games/sgt-puzzles/default.nix b/pkgs/games/sgt-puzzles/default.nix
index a161d8d68ef7..8173fb5fe1d2 100644
--- a/pkgs/games/sgt-puzzles/default.nix
+++ b/pkgs/games/sgt-puzzles/default.nix
@@ -60,15 +60,15 @@ stdenv.mkDerivation rec {
   '';
 
   passthru = {
-    tests.sgtpuzzles = nixosTests.sgtpuzzles;
-    updateScript = writeScript "update-sgtpuzzles" ''
+    tests.sgt-puzzles = nixosTests.sgt-puzzles;
+    updateScript = writeScript "update-sgt-puzzles" ''
       #!/usr/bin/env nix-shell
       #!nix-shell -i bash -p curl pcre common-updater-scripts
 
       set -eu -o pipefail
 
       version="$(curl -sI 'https://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles.tar.gz' | grep -Fi Location: | pcregrep -o1 'puzzles-([0-9a-f.]*).tar.gz')"
-      update-source-version sgtpuzzles "$version"
+      update-source-version sgt-puzzles "$version"
     '';
   };