about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2018-02-08 09:34:37 -0500
committerGitHub <noreply@github.com>2018-02-08 09:34:37 -0500
commit6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb (patch)
treed176bcd880e68e46ceb2c73949b6e5e6ea784c6d /pkgs/games
parentec506fdfbce811ad50037316dd4d19af1d4e3bdd (diff)
parenta5f91d1f15be06c066b04ec08fa1ab60ad44e9c2 (diff)
downloadnixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar.gz
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar.bz2
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar.lz
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar.xz
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.tar.zst
nixlib-6e782a0ef6c05ff2f72643fe49c58a226d9cf9bb.zip
Merge pull request #34572 from esoeylemez/ertes-bcc
doom-bcc-git: init at 2018.01.04
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/zdoom/bcc-git.nix31
-rw-r--r--pkgs/games/zdoom/bcc-warning-fix.patch25
2 files changed, 56 insertions, 0 deletions
diff --git a/pkgs/games/zdoom/bcc-git.nix b/pkgs/games/zdoom/bcc-git.nix
new file mode 100644
index 000000000000..2a1219e66ea0
--- /dev/null
+++ b/pkgs/games/zdoom/bcc-git.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation {
+  name = "doom-bcc-git-0.8.0.2018.01.04";
+
+  src = fetchFromGitHub {
+    owner = "wormt";
+    repo = "bcc";
+    rev = "d58b44d9f18b28fd732c27113e5607a454506d19";
+    sha256 = "1m83ip40ln61qrvb1fbgaqbld2xip9n3k817lwkk1936pml9zcrq";
+  };
+
+  enableParallelBuilding = true;
+  makeFlags = ["CC=cc"];
+
+  patches = [ ./bcc-warning-fix.patch ];
+
+  installPhase = ''
+    mkdir -p $out/{bin,lib,share/doc}
+    install -m755 bcc $out/bin/bcc
+    cp -av doc $out/share/doc/bcc
+    cp -av lib $out/lib/bcc
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Compiler for Doom/Hexen scripts (ACS, BCS)";
+    homepage = https://github.com/wormt/bcc;
+    license = licenses.mit;
+    maintainers = with maintainers; [ertes];
+  };
+}
diff --git a/pkgs/games/zdoom/bcc-warning-fix.patch b/pkgs/games/zdoom/bcc-warning-fix.patch
new file mode 100644
index 000000000000..4a352cb1e471
--- /dev/null
+++ b/pkgs/games/zdoom/bcc-warning-fix.patch
@@ -0,0 +1,25 @@
+From c6ac05c96b7908ccd35f3908fc0f13650b0583c0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ertugrul=20S=C3=B6ylemez?= <esz@posteo.de>
+Date: Sat, 3 Feb 2018 17:08:54 +0100
+Subject: [PATCH] Remove -Werror
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index bbe2c75..3357d2d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,7 +4,7 @@ EXE=bcc
+ BUILD_DIR=build
+ CC=gcc
+ INCLUDE=-Isrc -I src/parse
+-OPTIONS=-Wall -Werror -Wno-unused -std=c99 -pedantic -Wstrict-aliasing \
++OPTIONS=-Wall -Wno-unused -std=c99 -pedantic -Wstrict-aliasing \
+ 	-Wstrict-aliasing=2 -Wmissing-field-initializers -D_BSD_SOURCE \
+ 	-D_DEFAULT_SOURCE $(INCLUDE)
+ VERSION_FILE=$(BUILD_DIR)/version.c
+-- 
+2.15.1
+