about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSamuel Leathers <sam@appliedtrust.com>2017-09-01 08:54:58 -0400
committerSamuel Leathers <sam@appliedtrust.com>2017-09-01 08:56:30 -0400
commit6bc775cdf62bac2ae084f5173c91a350008dd4cd (patch)
treeb98d4d62c463a9b6fe544f890b606016fb5c997b /pkgs/games
parent86e6e8016d0f9280167745c19d394311be0f9002 (diff)
downloadnixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar.gz
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar.bz2
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar.lz
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar.xz
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.tar.zst
nixlib-6bc775cdf62bac2ae084f5173c91a350008dd4cd.zip
crrcsim: build with gcc6
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/crrcsim/default.nix4
-rw-r--r--pkgs/games/crrcsim/gcc6.patch13
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/games/crrcsim/default.nix b/pkgs/games/crrcsim/default.nix
index 68dfefad8d2e..23980c5842b4 100644
--- a/pkgs/games/crrcsim/default.nix
+++ b/pkgs/games/crrcsim/default.nix
@@ -14,6 +14,10 @@ stdenv.mkDerivation rec {
     mesa SDL SDL_mixer plib libjpeg
   ];
 
+  patches = [
+    ./gcc6.patch
+  ];
+
   meta = {
     description = "A model-airplane flight simulator";
     maintainers = with stdenv.lib.maintainers; [ raskin the-kenny ];
diff --git a/pkgs/games/crrcsim/gcc6.patch b/pkgs/games/crrcsim/gcc6.patch
new file mode 100644
index 000000000000..c19f28c514d7
--- /dev/null
+++ b/pkgs/games/crrcsim/gcc6.patch
@@ -0,0 +1,13 @@
+diff --git c/src/mod_video/crrc_animation.cpp i/src/mod_video/crrc_animation.cpp
+index ee7d7f4..855b106 100644
+--- c/src/mod_video/crrc_animation.cpp
++++ i/src/mod_video/crrc_animation.cpp
+@@ -84,7 +84,7 @@ void createAnimation(SimpleXMLTransfer *animation, ssgEntity* model)
+       else
+       {
+         std::cerr << "createAnimation: unknown animation type \'"
+-                  << type << "\'" << std::cerr;
++                  << type << "\'" << std::endl;
+       }
+       
+       if (anim != NULL)