about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-12-07 15:22:35 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-12-07 15:22:35 +0100
commit5f554279ec31e8d42266a3f4477035fa8e43a5c7 (patch)
tree0edb6eea939ec15ed533ca44b4d26ff4b97aea21 /pkgs/games
parent13ee78018cc0ebb8ff0ae25b6d86c9c273fd55b9 (diff)
parentcb2a447c510848c925977c0ecc440eef7443c12f (diff)
downloadnixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar.gz
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar.bz2
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar.lz
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar.xz
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.tar.zst
nixlib-5f554279ec31e8d42266a3f4477035fa8e43a5c7.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/anki/default.nix15
-rw-r--r--pkgs/games/assaultcube/default.nix3
-rw-r--r--pkgs/games/leela-zero/default.nix29
3 files changed, 43 insertions, 4 deletions
diff --git a/pkgs/games/anki/default.nix b/pkgs/games/anki/default.nix
index fb43640b2b12..3f837886116c 100644
--- a/pkgs/games/anki/default.nix
+++ b/pkgs/games/anki/default.nix
@@ -4,6 +4,7 @@
 , lib
 , python
 , fetchurl
+, fetchpatch
 , lame
 , mplayer
 , libpulseaudio
@@ -25,7 +26,7 @@
 }:
 
 buildPythonApplication rec {
-    version = "2.1.6-beta1";
+    version = "2.1.6-beta2";
     name = "anki-${version}";
 
     src = fetchurl {
@@ -35,7 +36,7 @@ buildPythonApplication rec {
         # "http://ankisrs.net/download/mirror/${name}.tgz"
         # "http://ankisrs.net/download/mirror/archive/${name}.tgz"
       ];
-      sha256 = "0yqn8qjx9dyf754jljhyyrk8mahii188nz0yifl1lr3py9sxzbsf";
+      sha256 = "0h71s1j1269x0b8481z8xf019caqglcjs32xlpzk72087ps169fa";
     };
 
     propagatedBuildInputs = [ pyqt5 sqlalchemy
@@ -53,6 +54,16 @@ buildPythonApplication rec {
     patches = [
       # Disable updated version check.
       ./no-version-check.patch
+
+      # This is needed to fix python 3.7 compatibilty, where the
+      # behaviour of `re.escape()` was changed in a way that it no
+      # longer escapes `%`. This patch detects this difference at
+      # runtime and makes anki work with any python version.
+      # Upstream PR: https://github.com/dae/anki/pull/266
+      (fetchpatch {
+        url = "https://github.com/dae/anki/commit/3d69aa9ce454a151ba75deafd7de117af2c7307d.patch";
+        sha256 = "0kf9gajhy0wcajp24xfia71z6gn1mc4vl37svvq4sqbhj3gigd0h";
+      })
     ];
 
     buildPhase = ''
diff --git a/pkgs/games/assaultcube/default.nix b/pkgs/games/assaultcube/default.nix
index 6f742bb64f79..71e885a04d34 100644
--- a/pkgs/games/assaultcube/default.nix
+++ b/pkgs/games/assaultcube/default.nix
@@ -8,8 +8,7 @@ stdenv.mkDerivation rec {
 
   # master branch has legacy (1.2.0.2) protocol 1201 and gcc 6 fix.
   pname = "assaultcube";
-  version = "01052017";
-  name = "${pname}-${version}";
+  version = "unstable-2017-05-01";
 
   meta = {
     description = "Fast and fun first-person-shooter based on the Cube fps";
diff --git a/pkgs/games/leela-zero/default.nix b/pkgs/games/leela-zero/default.nix
new file mode 100644
index 000000000000..c1238b7b3bbb
--- /dev/null
+++ b/pkgs/games/leela-zero/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, fetchFromGitHub, cmake, boost, eigen
+, opencl-headers, ocl-icd, qtbase , zlib }:
+
+stdenv.mkDerivation rec {
+  name = "leela-zero-${version}";
+  version = "0.16";
+
+  src = fetchFromGitHub {
+    owner = "gcp";
+    repo = "leela-zero";
+    rev = "v${version}";
+    sha256 = "1px7wqvlv414gklzgrmppp8wzc2mkskinm1p75j4snbqr8qpbn5s";
+    fetchSubmodules = true;
+  };
+
+  buildInputs = [ boost opencl-headers ocl-icd qtbase zlib ];
+
+  nativeBuildInputs = [ cmake ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Go engine modeled after AlphaGo Zero";
+    homepage    = https://github.com/gcp/leela-zero;
+    license     = licenses.gpl3;
+    maintainers = [ maintainers.averelld ];
+    platforms   = platforms.linux;
+  };
+}