about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-09-04 17:27:21 +0300
committerNikolay Amiantov <ab@fmap.me>2016-09-04 17:27:39 +0300
commit5d7adc7b093a00b3dc0ef97fa657160815161b9f (patch)
tree6946c3f3cc6862ad6f957474293779816c301956 /pkgs/games
parentee1b7f98799134f12981af3aacc3abbe2429d5bd (diff)
downloadnixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar.gz
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar.bz2
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar.lz
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar.xz
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.tar.zst
nixlib-5d7adc7b093a00b3dc0ef97fa657160815161b9f.zip
crawlTiles: fix build
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/crawl/crawl_purify.patch23
-rw-r--r--pkgs/games/crawl/default.nix4
2 files changed, 16 insertions, 11 deletions
diff --git a/pkgs/games/crawl/crawl_purify.patch b/pkgs/games/crawl/crawl_purify.patch
index 0e2d335adac2..bfd79844bcb6 100644
--- a/pkgs/games/crawl/crawl_purify.patch
+++ b/pkgs/games/crawl/crawl_purify.patch
@@ -1,8 +1,7 @@
-diff --git a/crawl-ref/source/Makefile b/crawl-ref/source/Makefile
-index b7e2fbf..5ff23db 100644
---- a/crawl-ref/source/Makefile
-+++ b/crawl-ref/source/Makefile
-@@ -273,7 +273,7 @@ endif
+diff -ru3 crawl-ref-0.18.1-src-old/crawl-ref/source/Makefile crawl-ref-0.18.1-src/crawl-ref/source/Makefile
+--- crawl-ref-0.18.1-src-old/crawl-ref/source/Makefile	1970-01-01 03:00:01.000000000 +0300
++++ crawl-ref-0.18.1-src/crawl-ref/source/Makefile	2016-09-04 17:25:54.310929928 +0300
+@@ -285,7 +285,7 @@
  LIBZ := contrib/install/$(ARCH)/lib/libz.a
  
  ifndef CROSSHOST
@@ -11,21 +10,27 @@ index b7e2fbf..5ff23db 100644
  else
  	# This is totally wrong, works only with some old-style setups, and
  	# on some architectures of Debian/new FHS multiarch -- excluding, for
-@@ -943,7 +943,7 @@ else
+@@ -957,9 +957,9 @@
    SYS_PROPORTIONAL_FONT = $(shell { name=$(OUR_PROPORTIONAL_FONT);\
      {\
        fc-list | sed 's/: .*//' | grep -Fi "/$$name";\
 -      for dir in /usr/share/fonts /usr/local/share/fonts /usr/*/lib/X11/fonts;\
 +      for dir in ${dejavu_fonts}/share/fonts;\
        do [ -d $$dir ] && echo $$dir; done;\
-     } | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
+-    } | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
++    } | xargs -I% find -L % -type f -iname $$name -print | head -n1; } 2>/dev/null)
    ifneq (,$(SYS_PROPORTIONAL_FONT))
-@@ -968,7 +968,7 @@ else
+     ifeq (,$(COPY_FONTS))
+       DEFINES += -DPROPORTIONAL_FONT=\"$(SYS_PROPORTIONAL_FONT)\"
+@@ -982,9 +982,9 @@
    SYS_MONOSPACED_FONT = $(shell { name=$(OUR_MONOSPACED_FONT);\
      {\
        fc-list | sed 's/: .*//' | grep -Fi "/$$name";\
 -      for dir in /usr/share/fonts /usr/local/share/fonts /usr/*/lib/X11/fonts;\
 +      for dir in ${dejavu_fonts}/share/fonts;\
        do [ -d $$dir ] && echo $$dir; done;\
-     } | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
+-    } | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
++    } | xargs -I% find -L % -type f -iname $$name -print | head -n1; } 2>/dev/null)
    ifneq (,$(SYS_MONOSPACED_FONT))
+     ifeq (,$(COPY_FONTS))
+       DEFINES += -DMONOSPACED_FONT=\"$(SYS_MONOSPACED_FONT)\"
diff --git a/pkgs/games/crawl/default.nix b/pkgs/games/crawl/default.nix
index 186768617f77..2a1e9232c230 100644
--- a/pkgs/games/crawl/default.nix
+++ b/pkgs/games/crawl/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, which, sqlite, lua5_1, perl, zlib, pkgconfig, ncurses
-, dejavu_fonts, libpng, SDL2, SDL2_image, mesa, freetype
+, dejavu_fonts, libpng, SDL2, SDL2_image, mesa, freetype, pngcrush
 , tileMode ? false
 }:
 
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
 
   patches = [ ./crawl_purify.patch ];
 
-  nativeBuildInputs = [ pkgconfig which perl ];
+  nativeBuildInputs = [ pkgconfig which perl pngcrush ];
 
   # Still unstable with luajit
   buildInputs = [ lua5_1 zlib sqlite ncurses ]