about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorWeijia Wang <9713184+wegank@users.noreply.github.com>2024-02-19 10:04:14 +0100
committerWeijia Wang <9713184+wegank@users.noreply.github.com>2024-02-19 10:04:14 +0100
commit566a57c3289a030baae8db1becb37b6e2123a3d1 (patch)
tree099d6e0fc1d2a281c0249ec170bb9ccad205859b /pkgs/games
parentf893cc7daacb331292b4bb7788846329b5fe79da (diff)
downloadnixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar.gz
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar.bz2
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar.lz
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar.xz
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.tar.zst
nixlib-566a57c3289a030baae8db1becb37b6e2123a3d1.zip
performous: 1.3.0 -> 1.3.1
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/performous/default.nix4
-rw-r--r--pkgs/games/performous/performous-cmake.patch29
2 files changed, 17 insertions, 16 deletions
diff --git a/pkgs/games/performous/default.nix b/pkgs/games/performous/default.nix
index c82e1d02afc7..1305d8409f97 100644
--- a/pkgs/games/performous/default.nix
+++ b/pkgs/games/performous/default.nix
@@ -23,13 +23,13 @@
 
 stdenv.mkDerivation rec {
   pname = "performous";
-  version = "1.3.0";
+  version = "1.3.1";
 
   src = fetchFromGitHub {
     owner = "performous";
     repo = "performous";
     rev = "refs/tags/${version}";
-    hash = "sha256-y7kxLht15vULN9NxM0wzj9+7Uq4/3D5j9oBEnrTIwQ8=";
+    hash = "sha256-f70IHA8LqIlkMRwJqSmszx3keStSx50nKcEWLGEjc3g=";
   };
 
   cedSrc = fetchFromGitHub {
diff --git a/pkgs/games/performous/performous-cmake.patch b/pkgs/games/performous/performous-cmake.patch
index dae399cd54de..6f56959792cd 100644
--- a/pkgs/games/performous/performous-cmake.patch
+++ b/pkgs/games/performous/performous-cmake.patch
@@ -1,17 +1,18 @@
 diff --git a/cmake/Modules/FindCed.cmake b/cmake/Modules/FindCed.cmake
-index d6e2aca..3085adb 100644
+index 5794bc84..08d6b49d 100644
 --- a/cmake/Modules/FindCed.cmake
 +++ b/cmake/Modules/FindCed.cmake
-@@ -1,11 +1 @@
--include(LibFetchMacros)
--
--set(Ced_GIT_VERSION "master")
--
--libfetch_git_pkg(Ced
--	REPOSITORY ${SELF_BUILT_GIT_BASE}/compact_enc_det.git
--	#https://github.com/google/compact_enc_det.git
--	REFERENCE  ${Ced_GIT_VERSION}
--	FIND_PATH  compact_enc_det/compact_enc_det.h
--)
--message(STATUS "Found Google CED ${Ced_VERSION}")
-+add_subdirectory(../ced-src ced-src)
+@@ -22,12 +22,7 @@ elseif(SELF_BUILT_CED STREQUAL "AUTO")
+ 	pkg_check_modules(CED IMPORTED_TARGET GLOBAL CED)
+ 	if(NOT CED_FOUND)
+ 		message(STATUS "ced build from source because not found on system")
+-		libfetch_git_pkg(Ced
+-			REPOSITORY ${SELF_BUILT_GIT_BASE}/compact_enc_det.git
+-			#https://github.com/google/compact_enc_det.git
+-			REFERENCE  ${Ced_GIT_VERSION}
+-			FIND_PATH  compact_enc_det/compact_enc_det.h
+-		)
++		add_subdirectory(../ced-src ced-src)
+ 	else()
+ 		add_library(ced ALIAS PkgConfig::CED)
+ 		set(Ced_VERSION ${CED_VERSION})