about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-09-03 15:01:51 +0200
committerVladimír Čunát <vcunat@gmail.com>2016-09-03 17:13:42 +0200
commit501668ee0a63081059526199b39c33850b2a0cba (patch)
tree3f2bb0629ed882ed48edacc0c314907915c46744 /pkgs/games
parent8939421da7db2e6d9d61e1f2ccc21d659f05c6b2 (diff)
downloadnixlib-501668ee0a63081059526199b39c33850b2a0cba.tar
nixlib-501668ee0a63081059526199b39c33850b2a0cba.tar.gz
nixlib-501668ee0a63081059526199b39c33850b2a0cba.tar.bz2
nixlib-501668ee0a63081059526199b39c33850b2a0cba.tar.lz
nixlib-501668ee0a63081059526199b39c33850b2a0cba.tar.xz
nixlib-501668ee0a63081059526199b39c33850b2a0cba.tar.zst
nixlib-501668ee0a63081059526199b39c33850b2a0cba.zip
teeworlds: update, cleanup
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/teeworlds/default.nix25
1 files changed, 13 insertions, 12 deletions
diff --git a/pkgs/games/teeworlds/default.nix b/pkgs/games/teeworlds/default.nix
index ef74903735d9..4485f7f2b9b7 100644
--- a/pkgs/games/teeworlds/default.nix
+++ b/pkgs/games/teeworlds/default.nix
@@ -1,19 +1,20 @@
-{ fetchurl, stdenv, python, alsaLib, libX11, mesa, SDL, lua5, zlib, bam, freetype }:
+{ fetchurl, stdenv, python, alsaLib, libX11, mesa_glu, SDL, lua5, zlib, bam, freetype }:
 
 stdenv.mkDerivation rec {
-  name = "teeworlds-0.6.1";
+  name = "teeworlds-0.6.3";
 
   src = fetchurl {
-    url = "http://www.teeworlds.com/files/${name}-source.tar.gz";
-    sha256 = "025rcz59mdqksja4akn888c8avj9j28rk86vw7w1licdp67x8a33";
+    url = "https://downloads.teeworlds.com/teeworlds-0.6.3-src.tar.gz";
+    sha256 = "0yq7f3yan07sxrhz7mzwqv344nfmdc67p3dg173631w9fb1yf3j9";
   };
 
-  # Note: Teeworlds requires Python 2.x to compile.  Python 3.0 will
-  # not work.
-  buildInputs = [ python alsaLib libX11 mesa SDL lua5 zlib bam freetype ];
+  # we always want to use system libs instead of these
+  postPatch = "rm -r other/{freetype,sdl}/{include,lib32,lib64}";
 
-  configurePhase = ''
-    bam release
+  buildInputs = [ python alsaLib libX11 mesa_glu SDL lua5 zlib bam freetype ];
+
+  buildPhase = ''
+    bam -a -v release
   '';
 
   installPhase = ''
@@ -39,9 +40,9 @@ stdenv.mkDerivation rec {
     do
       mv -v "$out/bin/$program" "$out/bin/.wrapped-$program"
       cat > "$out/bin/$program" <<EOF
-#!/bin/sh
-cd "$out/share/${name}" && exec "$out/bin/.wrapped-$program" "\$@"
-EOF
+    #!/bin/sh
+    cd "$out/share/${name}" && exec "$out/bin/.wrapped-$program" "\$@"
+    EOF
       chmod -v +x "$out/bin/$program"
     done