about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2020-12-20 15:32:01 -0800
committerJonathan Ringer <jonringer@users.noreply.github.com>2020-12-20 22:38:18 -0800
commit473ec944a100998cb557ca3c942212816760ba06 (patch)
tree93644ea6ca92833aafa3fbfee1434a16cbf9bc56 /pkgs/games
parent0179b5f17392f3e61d2b5af2ef3f741fbf72a3f3 (diff)
downloadnixlib-473ec944a100998cb557ca3c942212816760ba06.tar
nixlib-473ec944a100998cb557ca3c942212816760ba06.tar.gz
nixlib-473ec944a100998cb557ca3c942212816760ba06.tar.bz2
nixlib-473ec944a100998cb557ca3c942212816760ba06.tar.lz
nixlib-473ec944a100998cb557ca3c942212816760ba06.tar.xz
nixlib-473ec944a100998cb557ca3c942212816760ba06.tar.zst
nixlib-473ec944a100998cb557ca3c942212816760ba06.zip
steamPackages.steam: 1.0.0.61 -> 1.0.0.68
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/steam/steam.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/pkgs/games/steam/steam.nix b/pkgs/games/steam/steam.nix
index 20ccba641e4a..fa99f39d68cb 100644
--- a/pkgs/games/steam/steam.nix
+++ b/pkgs/games/steam/steam.nix
@@ -2,7 +2,7 @@
 
 let
   traceLog = "/tmp/steam-trace-dependencies.log";
-  version = "1.0.0.61";
+  version = "1.0.0.68";
 
 in stdenv.mkDerivation {
   pname = "steam-original";
@@ -10,7 +10,7 @@ in stdenv.mkDerivation {
 
   src = fetchurl {
     url = "https://repo.steampowered.com/steam/pool/steam/s/steam/steam_${version}.tar.gz";
-    sha256 = "0c5xy57gwr14vp3wy3jpqi5dl6y7n01p2dy4jlgl9bf9x7616r6n";
+    sha256 = "sha256-ZeiCYjxnH0Ath5bB20QHmE8R3wU4/3RiAw2NUhrrKNM=";
   };
 
   makeFlags = [ "DESTDIR=$(out)" "PREFIX=" ];
@@ -26,14 +26,16 @@ in stdenv.mkDerivation {
       EOF
       chmod +x $out/bin/steamdeps
     ''}
-    install -d $out/lib/udev/rules.d
-    install -m644 lib/udev/rules.d/*.rules $out/lib/udev/rules.d
+
+    # this just installs a link, "steam.desktop -> /lib/steam/steam.desktop"
+    rm $out/share/applications/steam.desktop
+    sed -e 's,/usr/bin/steam,steam,g' steam.desktop > $out/share/applications/steam.desktop
   '';
 
   meta = with stdenv.lib; {
     description = "A digital distribution platform";
     homepage = "http://store.steampowered.com/";
     license = licenses.unfreeRedistributable;
-    maintainers = with maintainers; [ jagajaga ];
+    maintainers = with maintainers; [ jagajaga jonringer ];
   };
 }