about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-07 18:00:57 +0000
committerGitHub <noreply@github.com>2023-12-07 18:00:57 +0000
commit40f2209184fa66523558b26efd0192b8299e69a1 (patch)
treeef9ddb9111a2293843e597e852af8a0b8fff8a00 /pkgs/games
parent860e5725bdfc7307b8257cbf9bf4a87dec978cc8 (diff)
parent1b6a085e031c2c47a979ee8238decb13831e664b (diff)
downloadnixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar.gz
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar.bz2
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar.lz
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar.xz
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.tar.zst
nixlib-40f2209184fa66523558b26efd0192b8299e69a1.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/armagetronad/default.nix2
-rw-r--r--pkgs/games/warzone2100/default.nix7
2 files changed, 3 insertions, 6 deletions
diff --git a/pkgs/games/armagetronad/default.nix b/pkgs/games/armagetronad/default.nix
index 275b878d2619..fb0117f3e93e 100644
--- a/pkgs/games/armagetronad/default.nix
+++ b/pkgs/games/armagetronad/default.nix
@@ -82,7 +82,7 @@ let
   let
     # Split the version into the major and minor parts
     versionParts = lib.splitString "-" version;
-    splitVersion = lib.splitString "." (builtins.elemAt versionParts 0);
+    splitVersion = lib.splitVersion (builtins.elemAt versionParts 0);
     majorVersion = builtins.concatStringsSep "." (lib.lists.take 2 splitVersion);
 
     minorVersionPart =  parts: sep: expectedSize:
diff --git a/pkgs/games/warzone2100/default.nix b/pkgs/games/warzone2100/default.nix
index 9979d16247c0..5dc2f6d4b8bb 100644
--- a/pkgs/games/warzone2100/default.nix
+++ b/pkgs/games/warzone2100/default.nix
@@ -46,11 +46,11 @@ in
 
 stdenv.mkDerivation rec {
   inherit pname;
-  version  = "4.4.0";
+  version  = "4.4.1";
 
   src = fetchurl {
     url = "mirror://sourceforge/${pname}/releases/${version}/${pname}_src.tar.xz";
-    hash = "sha256-Ul77OihJWIH9H6FUpibGDjqX1BY4DWDQ3bR4lRDY9+U=";
+    hash = "sha256-8vbwO4PXEOyZqGiSz1yqhe8jfe4E4iv908mc+8xuH8I=";
   };
 
   buildInputs = [
@@ -88,9 +88,6 @@ stdenv.mkDerivation rec {
                       --replace '"which "' '"${which}/bin/which "'
     substituteInPlace lib/exceptionhandler/exceptionhandler.cpp \
                       --replace "which %s" "${which}/bin/which %s"
-    # https://github.com/Warzone2100/warzone2100/pull/3353
-    substituteInPlace lib/ivis_opengl/gfx_api_vk.cpp \
-      --replace vk::throwResultException vk::detail::throwResultException
   '';
 
   cmakeFlags = [