about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-06 00:06:43 +0100
committerGraham Christensen <graham@grahamc.com>2017-12-12 18:08:10 -0500
commit3a110ea3f96db56012f7f2707e842593a7d7c5b8 (patch)
tree727bb87c20c860814a494875af0b874d3b977bbb /pkgs/games
parent76bf375a162d81d49b274eb07d6a33a74fe8850f (diff)
downloadnixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar.gz
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar.bz2
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar.lz
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar.xz
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.tar.zst
nixlib-3a110ea3f96db56012f7f2707e842593a7d7c5b8.zip
treewide platform checks: `abort` -> `throw`
They aren't meant to be critical (uncatchable) errors.
Tested with nix-env + checkMeta:
[ "x86_64-linux" "i686-linux" "x86_64-darwin" "aarch64-linux" ]
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/nethack/default.nix2
-rw-r--r--pkgs/games/steam/default.nix2
2 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/games/nethack/default.nix b/pkgs/games/nethack/default.nix
index 92d87697fb16..d9ab3ee833b2 100644
--- a/pkgs/games/nethack/default.nix
+++ b/pkgs/games/nethack/default.nix
@@ -3,7 +3,7 @@
 let
   platform =
     if lib.elem stdenv.system lib.platforms.unix then "unix"
-    else abort "Unknown platform for NetHack";
+    else throw "Unknown platform for NetHack: ${stdenv.system}";
   unixHint =
     if stdenv.isLinux then "linux"
     else if stdenv.isDarwin then "macosx10.10"
diff --git a/pkgs/games/steam/default.nix b/pkgs/games/steam/default.nix
index 54805e91b2bd..6a6485d43319 100644
--- a/pkgs/games/steam/default.nix
+++ b/pkgs/games/steam/default.nix
@@ -6,7 +6,7 @@ let
   self = rec {
     steamArch = if pkgs.stdenv.system == "x86_64-linux" then "amd64"
                 else if pkgs.stdenv.system == "i686-linux" then "i386"
-                else abort "Unsupported platform";
+                else throw "Unsupported platform: ${pkgs.stdenv.system}";
 
     steam-runtime = callPackage ./runtime.nix { };
     steam-runtime-wrapped = callPackage ./runtime-wrapped.nix { };