about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2018-03-09 17:42:18 +0000
committerGitHub <noreply@github.com>2018-03-09 17:42:18 +0000
commit36fd5663722ee504049bce543df7bc8a5092c0ef (patch)
tree781ddd518ec8176b7b3b16511eab7d06a29b54a7 /pkgs/games
parent72dede4203ae785f5cb27c6c811acafd1df51c6a (diff)
parent2dfeb6fc53788507c10c0738a85676d80ca6c970 (diff)
downloadnixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar.gz
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar.bz2
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar.lz
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar.xz
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.tar.zst
nixlib-36fd5663722ee504049bce543df7bc8a5092c0ef.zip
Merge pull request #36649 from pbogdan/pingus-fix-build
pingus: fix build with gcc7
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/pingus/default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/pkgs/games/pingus/default.nix b/pkgs/games/pingus/default.nix
index 68257fc9e9e4..e8bac9571f89 100644
--- a/pkgs/games/pingus/default.nix
+++ b/pkgs/games/pingus/default.nix
@@ -1,5 +1,5 @@
-{stdenv, fetchurl, scons, SDL, SDL_image, boost, libpng, SDL_mixer, pkgconfig
-, libGLU_combined}:
+{stdenv, fetchurl, fetchpatch, scons, SDL, SDL_image, boost, libpng, SDL_mixer
+, pkgconfig, libGLU_combined}:
 let
   s = # Generated upstream information
   rec {
@@ -18,6 +18,13 @@ stdenv.mkDerivation rec {
   src = fetchurl {
     inherit (s) url sha256;
   };
+  patches = [
+    # fix build with gcc7
+    (fetchpatch {
+      url = https://github.com/Pingus/pingus/commit/df6e2f445d3e2925a94d22faeb17be9444513e92.patch;
+      sha256 = "0nqyhznnnvpgfa6rfv8rapjfpw99b67n97jfqp9r3hpib1b3ja6p";
+    })
+  ];
   makeFlags = '' PREFIX="$(out)" '';
   meta = {
     inherit (s) version;