about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-09 21:00:07 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-09 21:00:07 +0100
commit2309acf72337b49eef43d1dfc90d850d2682a4a5 (patch)
tree645c03e7f03476375245bc064421b41329f21fb0 /pkgs/games
parent87317bab0a796b3c8301f27acfbf48a782d5dde0 (diff)
parent8f4f9b62238da74bd3c78fe5708369d543c3e690 (diff)
downloadnixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar.gz
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar.bz2
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar.lz
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar.xz
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.tar.zst
nixlib-2309acf72337b49eef43d1dfc90d850d2682a4a5.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/cataclysm-dda/git.nix6
-rw-r--r--pkgs/games/commandergenius/default.nix2
-rw-r--r--pkgs/games/freeorion/default.nix24
-rw-r--r--pkgs/games/gemrb/default.nix2
-rw-r--r--pkgs/games/lincity/ng.nix2
-rw-r--r--pkgs/games/residualvm/default.nix2
6 files changed, 21 insertions, 17 deletions
diff --git a/pkgs/games/cataclysm-dda/git.nix b/pkgs/games/cataclysm-dda/git.nix
index 1baff486c235..0437a1b130f8 100644
--- a/pkgs/games/cataclysm-dda/git.nix
+++ b/pkgs/games/cataclysm-dda/git.nix
@@ -2,14 +2,14 @@
 SDL2_mixer, freetype, gettext }:
 
 stdenv.mkDerivation rec {
-  version = "2017-07-12";
+  version = "2017-12-09";
   name = "cataclysm-dda-git-${version}";
 
   src = fetchFromGitHub {
     owner = "CleverRaven";
     repo = "Cataclysm-DDA";
-    rev = "2d7aa8c";
-    sha256 = "0xx7si4k5ivyb5gv98fzlcghrg3w0dfblri547x7x4is7fj5ffjd";
+    rev = "24e92956db5587809750283873c242cc0796d7e6";
+    sha256 = "1a7kdmx76na4g65zra01qaq98lxp9j2dl9ddv09r0p5yxaizw68z";
   };
 
   nativeBuildInputs = [ makeWrapper pkgconfig ];
diff --git a/pkgs/games/commandergenius/default.nix b/pkgs/games/commandergenius/default.nix
index 9baa38777068..b2a0b2884254 100644
--- a/pkgs/games/commandergenius/default.nix
+++ b/pkgs/games/commandergenius/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Modern Interpreter for the Commander Keen Games";
-    longdescription = ''
+    longDescription = ''
       Commander Genius is an open-source clone of
       Commander Keen which allows you to play
       the games, and some of the mods
diff --git a/pkgs/games/freeorion/default.nix b/pkgs/games/freeorion/default.nix
index 438b01fe51ac..61a1aed8178f 100644
--- a/pkgs/games/freeorion/default.nix
+++ b/pkgs/games/freeorion/default.nix
@@ -1,23 +1,27 @@
-{ stdenv, fetchurl, cmake, boost, SDL2, python2, freetype, openal, libogg, libvorbis, zlib, libpng, libtiff, libjpeg, mesa, glew, doxygen
-, libxslt, makeWrapper }:
+{ stdenv, fetchFromGitHub, cmake, doxygen, graphviz, makeWrapper
+, boost, SDL2, python2, freetype, openal, libogg, libvorbis, zlib, libpng, libtiff, libjpeg, mesa, glew, libxslt }:
 
 stdenv.mkDerivation rec {
-  version = "0.4.6";
+  version = "0.4.7.1";
   name = "freeorion-${version}";
 
-  src = fetchurl {
-    url = "https://github.com/freeorion/freeorion/releases/download/v0.4.6/FreeOrion_v0.4.6_2016-09-16.49f9123_Source.tar.gz";
-    sha256 = "04g3x1cymf7mnmc2f5mm3c2r5izjmy7z3pvk2ykzz8f8b2kz6gry";
+  src = fetchFromGitHub {
+    owner  = "freeorion";
+    repo   = "freeorion";
+    rev    = "v${version}";
+    sha256 = "1m05l3a6ilqd7p2g3aqjpq89grb571cg8n9bpgz0y3sxskcym6sp";
   };
 
-  buildInputs = [ cmake boost SDL2 python2 freetype openal libogg libvorbis zlib libpng libtiff libjpeg mesa glew doxygen makeWrapper ];
+  buildInputs = [ boost SDL2 python2 freetype openal libogg libvorbis zlib libpng libtiff libjpeg mesa glew ];
+
+  nativeBuildInputs = [ cmake doxygen graphviz makeWrapper ];
+
+  enableParallelBuilding = true;
 
   patches = [
     ./fix_rpaths.patch
   ];
 
-  enableParallelBuilding = true;
-
   postInstall = ''
     mkdir -p $out/fixpaths
     # We need final slashes for XSLT replace to work properly
@@ -36,7 +40,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "A free, open source, turn-based space empire and galactic conquest (4X) computer game";
     homepage = http://www.freeorion.org;
-    license = [ licenses.gpl2 licenses.cc-by-sa-30 ];
+    license = with licenses; [ gpl2 cc-by-sa-30 ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/games/gemrb/default.nix b/pkgs/games/gemrb/default.nix
index abe1c2c55991..0e9025259224 100644
--- a/pkgs/games/gemrb/default.nix
+++ b/pkgs/games/gemrb/default.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
     '';
     homepage = http://gemrb.org/;
     license = licenses.gpl2;
-    maintainer = with maintainers; [ peterhoeg ];
+    maintainers = with maintainers; [ peterhoeg ];
     platforms = platforms.all;
   };
 }
diff --git a/pkgs/games/lincity/ng.nix b/pkgs/games/lincity/ng.nix
index 4ca2cd271cdb..28fd6fe6e501 100644
--- a/pkgs/games/lincity/ng.nix
+++ b/pkgs/games/lincity/ng.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
    '';
 
   meta = {
-    documentation = ''City building game'';
+    description = ''City building game'';
     license = stdenv.lib.licenses.gpl2;
     platforms = stdenv.lib.platforms.linux;
     maintainers = [stdenv.lib.maintainers.raskin];
diff --git a/pkgs/games/residualvm/default.nix b/pkgs/games/residualvm/default.nix
index e96cf5e59322..d916ff0d3444 100644
--- a/pkgs/games/residualvm/default.nix
+++ b/pkgs/games/residualvm/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
     description = "Interpreter for LucasArts' Lua-based 3D adventure games";
     homepage = http://residualvm.org/;
     repositories.git = https://github.com/residualvm/residualvm.git;
-    licencse = licenses.gpl2;
+    license = licenses.gpl2;
     platforms = stdenv.lib.platforms.linux;
   };
 }