about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorFrancesco Gazzetta <fgaz@fgaz.me>2019-07-04 16:12:19 +0200
committerMatthieu Coudron <coudron@iij.ad.jp>2019-07-05 05:23:58 +0200
commit1c67718e235fa100edf3f5bf0189c344736b4aa8 (patch)
treeff692f0c3c032c19db3af2ea59e36dac455a3914 /pkgs/games
parent66d69c867e6cf767bbf2a47d2d9f9d92867bad27 (diff)
downloadnixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar.gz
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar.bz2
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar.lz
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar.xz
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.tar.zst
nixlib-1c67718e235fa100edf3f5bf0189c344736b4aa8.zip
curseofwar,curseofwar-sdl: init at 1.2.0
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/curseofwar/default.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/games/curseofwar/default.nix b/pkgs/games/curseofwar/default.nix
new file mode 100644
index 000000000000..8b915345f862
--- /dev/null
+++ b/pkgs/games/curseofwar/default.nix
@@ -0,0 +1,41 @@
+{ stdenv
+, fetchFromGitHub
+, fetchpatch
+, ncurses
+, SDL
+}:
+
+stdenv.mkDerivation rec {
+  pname = "curseofwar";
+  version = "1.2.0";
+
+  src = fetchFromGitHub {
+    owner = "a-nikolaev";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1bj3lv5vrnwzzkgj31pyf1lzkz10qphvzlfz7a3j4plqkczjq92y";
+  };
+
+  patches = [(fetchpatch {
+    # Pull request #40: https://github.com/a-nikolaev/curseofwar/pull/40
+    name = "prefix-independent-data";
+    url = "https://github.com/fgaz/curseofwar/commit/947dea527b2bf4c6e107b8e9c66f4c4fd775b6f9.patch";
+    sha256 = "0ak5igaxmbavkbl8101xx6gswhwgzm5f6wyplwapgh7cylnclc61";
+  })];
+
+  buildInputs = [
+    ncurses
+    SDL
+  ];
+
+  makeFlags = (if isNull SDL then [] else [ "SDL=yes" ]) ++ [ "PREFIX=$(out)" ];
+
+  meta = with stdenv.lib; {
+    description = "A fast-paced action strategy game";
+    homepage = "https://a-nikolaev.github.io/curseofwar/";
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ fgaz ];
+    platforms = platforms.all;
+  };
+}
+