about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorBobby Rong <rjl931189261@126.com>2022-03-25 10:50:53 +0800
committerBobby Rong <rjl931189261@126.com>2022-03-25 10:50:53 +0800
commit1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d (patch)
treeddebd2fda444f44cb9d51de4c4ac66583cfe63c6 /pkgs/games
parent9bc841fec1c0e8b9772afa29f934d2c7ce57da8e (diff)
downloadnixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar.gz
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar.bz2
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar.lz
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar.xz
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.tar.zst
nixlib-1c46c8f7d854fd65853bacbbcf9b8e14746b7b7d.zip
gnonograms: fix build with meson 0.61
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/gnonograms/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/pkgs/games/gnonograms/default.nix b/pkgs/games/gnonograms/default.nix
index cfe1085ca27b..21f522d3418f 100644
--- a/pkgs/games/gnonograms/default.nix
+++ b/pkgs/games/gnonograms/default.nix
@@ -1,6 +1,7 @@
 { lib
 , stdenv
 , fetchFromGitHub
+, fetchpatch
 , vala
 , meson
 , ninja
@@ -27,6 +28,15 @@ stdenv.mkDerivation rec {
     sha256 = "sha256-2uXaybpCAm9cr0o7bqfhgD7mMNPwtv1X/PgnFnSDOl0=";
   };
 
+  patches = [
+    # Fix build with meson 0.61, can be removed on next release
+    # https://github.com/jeremypw/gnonograms/pull/45
+    (fetchpatch {
+      url = "https://github.com/jeremypw/gnonograms/commit/0e90d8ff42d64a94002ec8500889bc4d7e06c1b6.patch";
+      sha256 = "sha256-G/yqsZFmOA69A3E2CROMYAS5vmok/K5l1S/M2m8DMh4=";
+    })
+  ];
+
   postPatch = ''
     patchShebangs meson/post_install.py
   '';