about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorYegor Timoshenko <yegortimoshenko@riseup.net>2018-06-05 22:08:53 +0300
committerGitHub <noreply@github.com>2018-06-05 22:08:53 +0300
commit1786883011a9f90b0670691e0bca95617e617ffa (patch)
treeafd0d9baf754ac16b503414cdcbd55ed718286fa /pkgs/games
parent3cc263ea132572ecb498b11e4baa8efb2faa3f89 (diff)
parent0edad9f5c8d3deb6950537256f6077c2b086896c (diff)
downloadnixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar.gz
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar.bz2
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar.lz
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar.xz
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.tar.zst
nixlib-1786883011a9f90b0670691e0bca95617e617ffa.zip
Merge pull request #41432 from ajs124/steam_profile_override
steam: add optional extraProfile
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/steam/chrootenv.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/games/steam/chrootenv.nix b/pkgs/games/steam/chrootenv.nix
index c44a166268cc..4de5f6608186 100644
--- a/pkgs/games/steam/chrootenv.nix
+++ b/pkgs/games/steam/chrootenv.nix
@@ -3,6 +3,7 @@
 , withJava ? false
 , withPrimus ? false
 , extraPkgs ? pkgs: [ ] # extra packages to add to targetPkgs
+, extraProfile ? "" # string to append to profile
 , nativeOnly ? false
 , runtimeOnly ? false
 }:
@@ -178,7 +179,7 @@ in buildFHSUserEnv rec {
 
   profile = ''
     export STEAM_RUNTIME=${if nativeOnly then "0" else "/steamrt"}
-  '';
+  '' + extraProfile;
 
   runScript = writeScript "steam-wrapper.sh" ''
     #!${stdenv.shell}