about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorLouis Taylor <louis@kragniz.eu>2016-05-29 00:53:56 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2016-06-16 15:54:22 +0200
commit160aeab22d55013e2bc70bae504855261c7cf889 (patch)
tree19cbe7887c3bed612eb16604103fdeef44a53f95 /pkgs/games
parentaa8eba9d9569c61ddec6fdebfa769a7f4ccb9256 (diff)
downloadnixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar.gz
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar.bz2
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar.lz
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar.xz
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.tar.zst
nixlib-160aeab22d55013e2bc70bae504855261c7cf889.zip
openrw: init at 2016-06-29
Closes #15794
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/openrw/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/games/openrw/default.nix b/pkgs/games/openrw/default.nix
new file mode 100644
index 000000000000..0c235383acff
--- /dev/null
+++ b/pkgs/games/openrw/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchgit, cmake, sfml, mesa, bullet, glm, libmad, x11 }:
+
+stdenv.mkDerivation rec {
+  version = "2016-06-29";
+  name = "openrw-${version}";
+  src = fetchgit {
+    url = "https://github.com/rwengine/openrw";
+    rev = "46a7254a41d9f6e1eda8d31e742de492abb2540e";
+    sha256 = "16ip9779dy59xcj9src2i4zp8jq2h0h5mb4a7d5cpkhd3xlcpabm";
+    fetchSubmodules = true;
+  };
+
+  buildInputs = [ cmake sfml mesa bullet glm libmad x11 ];
+
+  meta = with stdenv.lib; {
+    description = "Unofficial open source recreation of the classic Grand Theft Auto III game executable";
+    homepage = https://github.com/rwengine/openrw;
+    license = licenses.gpl3;
+    longDescription = ''
+      OpenRW is an open source re-implementation of Rockstar Games' Grand Theft
+      Auto III, a classic 3D action game first published in 2001.
+    '';
+    maintainers = with maintainers; [ kragniz ];
+    platforms = platforms.all;
+  };
+}