about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2024-01-10 16:09:42 +0100
committerMartin Weinelt <hexa@darmstadt.ccc.de>2024-01-10 16:09:52 +0100
commit10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5 (patch)
treedaeae66b677e82faa252f0721af6f2e40411e39b /pkgs/games
parent3c4b68b54d7123b14ff0c5c40e67883c32afe3dd (diff)
parentfb8c64e6a1d68202edc93d284eb491fd266db0d0 (diff)
downloadnixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar.gz
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar.bz2
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar.lz
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar.xz
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.tar.zst
nixlib-10b01dcc8907eb56a67a14fb210f7c5be1c8a2e5.zip
Merge remote-tracking branch 'origin/master' into staging-next
Conflicts:
-	pkgs/development/python-modules/types-setuptools/default.nix
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/frotz/default.nix29
1 files changed, 17 insertions, 12 deletions
diff --git a/pkgs/games/frotz/default.nix b/pkgs/games/frotz/default.nix
index 9b5256fc1c72..9bc7ae5ae512 100644
--- a/pkgs/games/frotz/default.nix
+++ b/pkgs/games/frotz/default.nix
@@ -1,4 +1,7 @@
-{ fetchFromGitLab
+{ lib
+, stdenv
+, fetchFromGitLab
+, fetchpatch
 , libao
 , libmodplug
 , libsamplerate
@@ -7,29 +10,31 @@
 , ncurses
 , which
 , pkg-config
-, lib, stdenv }:
+}:
 
 stdenv.mkDerivation rec {
-  version = "2.53";
   pname = "frotz";
+  version = "2.54";
 
   src = fetchFromGitLab {
     domain = "gitlab.com";
     owner = "DavidGriffith";
     repo = "frotz";
     rev = version;
-    sha256 = "sha256-xVC/iE71W/Wdy5aPGH9DtcVAHWCcg3HkEA3iDV6OYUo=";
+    hash = "sha256-GvGxojD8d5GVy/d8h3q6K7KJroz2lsKbfE0F0acjBl8=";
   };
 
+  patches = [
+    (fetchpatch {
+      url = "https://github.com/macports/macports-ports/raw/496e5b91e3b6c9dc6820d77ab60dbe400d1924ee/games/frotz/files/Makefile.patch";
+      extraPrefix = "";
+      hash = "sha256-P83ZzSi3bhncQ52Y38Q3F/7v1SJKr5614tytt862HRg=";
+    })
+  ];
+
   nativeBuildInputs = [ which pkg-config ];
   buildInputs = [ libao libmodplug libsamplerate libsndfile libvorbis ncurses ];
-  preBuild = ''
-    makeFlagsArray+=(
-      CC="cc"
-      CFLAGS="-D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600"
-      LDFLAGS="-lncursesw -ltinfo"
-    )
-  '';
+
   installFlags = [ "PREFIX=$(out)" ];
 
   meta = with lib; {
@@ -37,7 +42,7 @@ stdenv.mkDerivation rec {
     changelog = "https://gitlab.com/DavidGriffith/frotz/-/raw/${version}/NEWS";
     description = "A z-machine interpreter for Infocom games and other interactive fiction";
     platforms = platforms.unix;
-    maintainers = with maintainers; [ nicknovitski  ddelabru ];
+    maintainers = with maintainers; [ nicknovitski ddelabru ];
     license = licenses.gpl2;
   };
 }