about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorAnton Bulakh <self@necauqua.dev>2023-02-18 07:43:44 +0200
committerAnton Bulakh <him@necauq.ua>2024-01-26 20:34:37 +0200
commit0a81bc8cd2c8483937d0e641ac78e67930cf579c (patch)
treede24043634b8c7e117d63a145c4136d6b7197ae2 /pkgs/games
parent1704052d67a93984ea2836455e282b2df36b7711 (diff)
downloadnixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar.gz
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar.bz2
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar.lz
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar.xz
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.tar.zst
nixlib-0a81bc8cd2c8483937d0e641ac78e67930cf579c.zip
starsector: fix the icon symlink
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/starsector/default.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/pkgs/games/starsector/default.nix b/pkgs/games/starsector/default.nix
index 2dbb0ed54791..f40ae8857366 100644
--- a/pkgs/games/starsector/default.nix
+++ b/pkgs/games/starsector/default.nix
@@ -1,6 +1,5 @@
 { lib
 , fetchzip
-, libXxf86vm
 , libGL
 , makeWrapper
 , openal
@@ -48,7 +47,8 @@ stdenv.mkDerivation rec {
     cp -r ./* $out/share/starsector
 
     mkdir -p $out/share/icons/hicolor/64x64/apps
-    ln -s $out/graphics/ui/s_icon64.png $out/share/icons/hicolor/64x64/apps/starsector.png
+    ln -s $out/share/starsector/graphics/ui/s_icon64.png \
+      $out/share/icons/hicolor/64x64/apps/starsector.png
 
     wrapProgram $out/share/starsector/starsector.sh \
       --prefix PATH : ${lib.makeBinPath [ openjdk xorg.xrandr ]} \
@@ -71,14 +71,6 @@ stdenv.mkDerivation rec {
       --replace "-XX:+CompilerThreadHintNoPreempt" "-XX:+UnlockDiagnosticVMOptions -XX:-BytecodeVerificationRemote -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSConcurrentMTEnabled -XX:+DisableExplicitGC"
   '';
 
-  meta = with lib; {
-    description = "Open-world single-player space-combat, roleplaying, exploration, and economic game";
-    homepage = "https://fractalsoftworks.com";
-    sourceProvenance = with sourceTypes; [ binaryBytecode ];
-    license = licenses.unfree;
-    maintainers = with maintainers; [ bbigras rafaelrc ];
-  };
-
   passthru.updateScript = writeScript "starsector-update-script" ''
     #!/usr/bin/env nix-shell
     #!nix-shell -i bash -p curl gnugrep common-updater-scripts
@@ -86,4 +78,12 @@ stdenv.mkDerivation rec {
     version=$(curl -s https://fractalsoftworks.com/preorder/ | grep -oP "https://f005.backblazeb2.com/file/fractalsoftworks/release/starsector_linux-\K.*?(?=\.zip)" | head -1)
     update-source-version ${pname} "$version" --file=./pkgs/games/starsector/default.nix
   '';
+
+  meta = with lib; {
+    description = "Open-world single-player space-combat, roleplaying, exploration, and economic game";
+    homepage = "https://fractalsoftworks.com";
+    sourceProvenance = with sourceTypes; [ binaryBytecode ];
+    license = licenses.unfree;
+    maintainers = with maintainers; [ bbigras rafaelrc ];
+  };
 }