about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorJonathan Baldwin <jbal@jbal.me>2020-12-13 14:01:21 -0500
committerJonathan Ringer <jonringer@users.noreply.github.com>2020-12-16 14:04:44 -0800
commit0127c297132948d6c79a38a8f49f24bcb0d23441 (patch)
tree400f9a397cff44b930bd2b9ed7fa697f25e85925 /pkgs/games
parentb83e5b85bd373bafb292f56b3869799ebef90ba8 (diff)
downloadnixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar.gz
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar.bz2
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar.lz
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar.xz
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.tar.zst
nixlib-0127c297132948d6c79a38a8f49f24bcb0d23441.zip
steam/fhsenv: Add LD_LIBRARY_PATH (and hence OpenGL driver library path) to output of --print-steam-runtime-library-paths
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/steam/fhsenv.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/games/steam/fhsenv.nix b/pkgs/games/steam/fhsenv.nix
index d3d5b3a2271e..6f9d13671dc4 100644
--- a/pkgs/games/steam/fhsenv.nix
+++ b/pkgs/games/steam/fhsenv.nix
@@ -60,7 +60,7 @@ let
     #!${runtimeShell}
     runtime_paths="/lib32:/lib64:${lib.concatStringsSep ":" ldPath}"
     if [ "$1" == "--print-steam-runtime-library-paths" ]; then
-      echo "$runtime_paths"
+      echo "$runtime_paths''${LD_LIBRARY_PATH:+:}$LD_LIBRARY_PATH"
       exit 0
     fi
     export LD_LIBRARY_PATH="$runtime_paths''${LD_LIBRARY_PATH:+:}$LD_LIBRARY_PATH"