about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorTheodore Ni <3806110+tjni@users.noreply.github.com>2023-08-30 11:04:28 -0700
committerMartin Weinelt <hexa@darmstadt.ccc.de>2023-09-27 15:32:44 +0200
commit00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44 (patch)
tree09900d4299955662975f2b0eae360516c087e997 /pkgs/games
parent31a7d7ba4cc389d4fda0fba97d9be2e1ae393ea7 (diff)
downloadnixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar.gz
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar.bz2
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar.lz
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar.xz
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.tar.zst
nixlib-00ee658dfbcaac61a80a0b7ba1bb33d5b5caca44.zip
portmod: 2.1.0 -> 2.6.2
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/portmod/default.nix25
1 files changed, 19 insertions, 6 deletions
diff --git a/pkgs/games/portmod/default.nix b/pkgs/games/portmod/default.nix
index c67626d0b005..f9631c6d764f 100644
--- a/pkgs/games/portmod/default.nix
+++ b/pkgs/games/portmod/default.nix
@@ -12,20 +12,20 @@
 }:
 
 let
-  version = "2.1.0";
+  version = "2.6.2";
 
   src = fetchFromGitLab {
     owner = "portmod";
     repo = "Portmod";
     rev = "v${version}";
-    hash = "sha256-b/ENApFovMPNUMbJhwY+TZCnSzpr1e/IKJ/5XAGTQjE=";
+    hash = "sha256-ufr2guaPdCvI5JOicL/lTrT3t6UlaY1hEB2xbwzhw6A=";
   };
 
   portmod-rust = rustPlatform.buildRustPackage rec {
     inherit src version;
     pname = "portmod-rust";
 
-    cargoHash = "sha256-3EfMMpSWSYsB3nXaoGGDuKQ9duyCKzbrT6oeATnzqLE=";
+    cargoHash = "sha256-sAjgGVVjgXaWbmN/eGEvatYjkHeFTZNX1GXFcJqs3GI=";
 
     nativeBuildInputs = [
       python3Packages.python
@@ -49,22 +49,32 @@ python3Packages.buildPythonApplication rec {
   inherit src version;
 
   pname = "portmod";
+  format = "pyproject";
 
-  SETUPTOOLS_SCM_PRETEND_VERSION = version;
+  env.SETUPTOOLS_SCM_PRETEND_VERSION = version;
 
   # build the rust library independantly
   prePatch = ''
     substituteInPlace setup.py \
-      --replace "from setuptools_rust import Binding, RustExtension" "" \
-      --replace "RustExtension(\"portmodlib.portmod\", binding=Binding.PyO3, strip=True)" ""
+      --replace "from setuptools_rust import Binding, RustExtension, Strip" "" \
+      --replace "RustExtension(\"portmodlib.portmod\", binding=Binding.PyO3, strip=Strip.Debug)" ""
+
+    substituteInPlace pyproject.toml \
+      --replace '"setuptools-rust"' ""
   '';
 
+  nativeBuildInputs = with python3Packages; [
+    setuptools
+    wheel
+  ];
+
   propagatedBuildInputs = with python3Packages; [
     setuptools-scm
     setuptools
     requests
     chardet
     colorama
+    deprecated
     restrictedpython
     appdirs
     gitpython
@@ -95,6 +105,9 @@ python3Packages.buildPythonApplication rec {
     "test_sync"
     "test_manifest"
     "test_add_repo"
+    "test_init_prefix_interactive"
+    "test_scan_sources"
+    "test_unpack"
   ];
 
   # for some reason, installPhase doesn't copy the compiled binary